summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-03 00:24:57 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-03 00:25:13 +0100
commitc4ad931603db84b8bcafc69b1194c9acefb5e088 (patch)
tree747bac0a181c242d72c67d549caf78ecc4c5ff0a /app-misc/tpconfig
parentapp-misc/mepl: rename patch. (diff)
downloadgentoo-c4ad931603db84b8bcafc69b1194c9acefb5e088.tar.gz
gentoo-c4ad931603db84b8bcafc69b1194c9acefb5e088.tar.bz2
gentoo-c4ad931603db84b8bcafc69b1194c9acefb5e088.zip
app-misc/tpconfig: EAPI 6 bump.
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-misc/tpconfig')
-rw-r--r--app-misc/tpconfig/tpconfig-3.1.3-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/tpconfig/tpconfig-3.1.3-r2.ebuild b/app-misc/tpconfig/tpconfig-3.1.3-r2.ebuild
new file mode 100644
index 000000000000..8a15af17edf5
--- /dev/null
+++ b/app-misc/tpconfig/tpconfig-3.1.3-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Touchpad config for ALPS and Synaptics TPs. Controls tap/click behaviour"
+HOMEPAGE="http://www.compass.com/synaptics/"
+SRC_URI="http://www.compass.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README AUTHORS NEWS INSTALL )
+
+src_compile() {
+ econf
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin "${PN}"
+ doinitd "${FILESDIR}"/"${PN}"
+ newconfd "${FILESDIR}"/"${PN}.conf" "${PN}"
+}