summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/smtm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/smtm')
-rw-r--r--app-misc/smtm/Manifest1
-rw-r--r--app-misc/smtm/metadata.xml7
-rw-r--r--app-misc/smtm/smtm-1.6.10-r1.ebuild33
3 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/smtm/Manifest b/app-misc/smtm/Manifest
new file mode 100644
index 000000000000..35faf45a61b8
--- /dev/null
+++ b/app-misc/smtm/Manifest
@@ -0,0 +1 @@
+DIST smtm_1.6.10.tar.gz 54033 SHA256 bad7fe5ebdf93db5e63855abe05cda739882f2d455aac4d25a5519e87935c825 SHA512 0cacafb8cfe1411b6b5db677bf15ad731b2e2181ee14ff8374e1fa01ad931e8f92efff29774e84950178f20805b18518067643e3c98d7990e1d1b93b7dd347d9 WHIRLPOOL 9c7b5254351adc44f994a07245056b88336b0ce08a4b35c7455794a7ff034314d45d24e6816d737ecf2152321c1ebfd347d6a69ef7604f39ebdb1c8fb6ec4a97
diff --git a/app-misc/smtm/metadata.xml b/app-misc/smtm/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/app-misc/smtm/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/smtm/smtm-1.6.10-r1.ebuild b/app-misc/smtm/smtm-1.6.10-r1.ebuild
new file mode 100644
index 000000000000..14a034469bf8
--- /dev/null
+++ b/app-misc/smtm/smtm-1.6.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Stock ticker, profit/loss calculator and chart tool"
+HOMEPAGE="http://eddelbuettel.com/dirk/code/smtm.html"
+SRC_URI="http://eddelbuettel.com/dirk/code/smtm/smtm_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+# This warrants USE examples
+IUSE=""
+
+DEPEND="dev-perl/perl-tk
+ dev-perl/DateManip
+ dev-perl/HTML-Parser
+ dev-perl/Finance-YahooQuote
+ dev-perl/libwww-perl"
+
+SRC_TEST="do parallel"
+
+src_install() {
+ perl-module_src_install
+ # install examples into own folder for now
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/examples
+ doins examples/*
+}