summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPunarbasu Purkayastha <ppurka@gmail.com>2023-03-29 22:34:31 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-04-10 10:37:21 +0300
commitef5632f626a7bf476ccc04ef26bd2790158f3957 (patch)
treec94049258803cc23d8fa84817f9a320b8bb4d4c5 /app-misc/recoll
parentmedia-gfx/converseen: add subslot binders to {graphics,image}magic (diff)
downloadgentoo-ef5632f626a7bf476ccc04ef26bd2790158f3957.tar.gz
gentoo-ef5632f626a7bf476ccc04ef26bd2790158f3957.tar.bz2
gentoo-ef5632f626a7bf476ccc04ef26bd2790158f3957.zip
app-misc/recoll: Version bump to 1.34.6, Add Python 3.11
Closes: https://bugs.gentoo.org/896594 Signed-off-by: Punarbasu Purkayastha <ppurka@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30404 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/recoll')
-rw-r--r--app-misc/recoll/Manifest1
-rw-r--r--app-misc/recoll/recoll-1.34.6.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index 40b1ea78e630..855a01a996ef 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -3,3 +3,4 @@ DIST recoll-1.32.0.tar.gz 3622960 BLAKE2B 74adc5861d7eeaa3240471444622a4cf638a11
DIST recoll-1.32.2.tar.gz 3648813 BLAKE2B 091df122d9d484ad2247a96da2a376cf0884349ab57e4be4cf31bc2abd175741cc1eb82084706f23445f1b47f13a5819916e2d48f10e4fab6e498bb34e99eea4 SHA512 6e0c51867306cd13cb09fcdebc60d8fef97ab680d22425eb58e398ab4d119bf58e19e21e986309ade25a4d6fe2ff0d33eaa44826fcddc2f5d401df159c3f865f
DIST recoll-1.32.5.tar.gz 3647176 BLAKE2B e2f6ed2866283cf2f3f0c70612c2d3b0ac26c5a6ef559d8ff0f5ff027c04d0878623597ba23d8cad73f9f0ee0ba869b66166e193b836e7b23695b14c494a45fa SHA512 ea7242d7a3cbba66bb9f90523388b097263b370a1f11b09e5ad63ac58cdcea74db1ae17e312b81efcda6cfd856c02b7f961a57dbacd7c5b6b1a76f9afa89622e
DIST recoll-1.33.4.tar.gz 3685945 BLAKE2B 67c151fcc58c4450d6e03606b245998c76136e195d5fe9830862f0a18da7becd56399c0086d016763b8fb91ef6e59ea988ee236d053a4f53ca6e9c64b94b86de SHA512 4c54803024b996e1e154f570566dc6132a8888e0f8fb803154f64a779c87b827971153ff3187b5769bb6c495dfb25e30d029c5118a87a65b6fa788c220ee6c48
+DIST recoll-1.34.6.tar.gz 3078366 BLAKE2B 91ae9e72851b008da61e41a1ddd5091b20b3e683506970e01f39eb2e3b5dfc174ebbc213ef29daede601322b21783ea34e34e04992447375015189c8fdec9d71 SHA512 f151a8f3575af41277fc9b50bb9a5e2ea1348e035b3dead36b47d1d6918deb755a4d59913d174db48273afdd95f4a063aa20219f1116a6d83c82fb063dbf16b7
diff --git a/app-misc/recoll/recoll-1.34.6.ebuild b/app-misc/recoll/recoll-1.34.6.ebuild
new file mode 100644
index 000000000000..7efe337355e8
--- /dev/null
+++ b/app-misc/recoll/recoll-1.34.6.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit linux-info optfeature python-single-r1 qmake-utils systemd
+
+DESCRIPTION="Personal full text search package"
+HOMEPAGE="https://www.lesbonscomptes.com/recoll/"
+SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="camelcase chm +inotify qt5 session +spell systemd webengine"
+REQUIRED_USE="
+ session? ( inotify )
+ webengine? ( qt5 )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xapian:=
+ sys-libs/zlib
+ virtual/libiconv
+ chm? (
+ dev-libs/chmlib
+ dev-python/pychm
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ systemd? ( sys-apps/systemd )
+ ${PYTHON_DEPS}
+"
+
+BDEPEND="
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+"
+
+pkg_setup() {
+ if use inotify; then
+ local CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+ local myeconfargs=(
+ $(use_enable camelcase)
+ $(use_enable chm python-chm)
+ $(use_enable session x11mon)
+ $(use_enable qt5 qtgui)
+ $(use_enable webengine)
+ $(use_with inotify)
+ $(use_with spell aspell)
+ $(use_with systemd)
+ --with-system-unit-dir="$(systemd_get_systemunitdir)"
+ --with-user-unit-dir="$(systemd_get_userunitdir)"
+ --disable-webkit
+ --without-fam
+ --enable-recollq
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIP="$(type -P true || die)" DESTDIR="${D}" install
+ python_optimize
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ dodoc -r "${ED}"/usr/share/recoll/doc/.
+ rm -r "${ED}/usr/share/recoll/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" dev-text/detex
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}