summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-18 00:18:56 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-18 00:29:36 +0200
commit9da1bce4c63d46e68b18c63dcca8b48a511498f4 (patch)
tree56ad2e2144a77bbfc9286354e296a0efebe0d1cc /app-misc/kryoflux-dtc
parentdev-lua/luarocks: drop 3.9.2, 3.10.0 (diff)
downloadgentoo-9da1bce4c63d46e68b18c63dcca8b48a511498f4.tar.gz
gentoo-9da1bce4c63d46e68b18c63dcca8b48a511498f4.tar.bz2
gentoo-9da1bce4c63d46e68b18c63dcca8b48a511498f4.zip
app-misc/kryoflux-dtc: add 3.50_p2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc/kryoflux-dtc')
-rw-r--r--app-misc/kryoflux-dtc/Manifest1
-rw-r--r--app-misc/kryoflux-dtc/kryoflux-dtc-3.50_p2.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/app-misc/kryoflux-dtc/Manifest b/app-misc/kryoflux-dtc/Manifest
index 2a87dbcc9db7..572359b6b8cd 100644
--- a/app-misc/kryoflux-dtc/Manifest
+++ b/app-misc/kryoflux-dtc/Manifest
@@ -1,3 +1,4 @@
DIST kryoflux_2.6_linux.tar.bz2 9177658 BLAKE2B 6eb0bc7a166950bfedb32da466c17125a8a7d64e4bc9aa6610c69dd0f98c2fb5187ad19dbaf191b33dcb5a786ec4a1fa9bce2464c3c04eb152e0b9ed7ae770f2 SHA512 9bf700e9c646bad135999eb1fed12c86ff6fbc11a0034b86af7541fb16a4905dd740c706ebb87bf5848f5d80f45699c350a56397df5b6850559c2576d18eef1b
DIST kryoflux_3.00_linux.tgz 13921877 BLAKE2B aceb934ec7b0b9d5d1d96555dceeeaa5eb11af67b1aae91888376a2c7615d4ed135167d4c3ea0ae3851a378e5fd5934aacd557a57e28e824c9131efcb87bc59e SHA512 0f4e805373c769bc81659ff93d6f8001103a6a192ca30c73b84cde231d52aa51950860fb9e11c156800d40ebbcd7cc33253f0fcbd436e8668731836f9689c013
DIST kryoflux_3.00_windows.zip 18211783 BLAKE2B e50cfc196d37216a7c929c4aa915b5cfeb7f38805076aed4e1bbc9dbfcc946fce18db0a2e2020d77cf581e2df174f2e3b6eb2b3d9060795501b1769d258ad05d SHA512 afa42fd3460d796dd3694059a86484ea94ab3084c52dc18d6f14e5b790d66e0f13514fbe2efc5c32abd3e471cdb0ac10cc3f7bafcdfb41371a6caddda83e2a00
+DIST kryoflux_3.50_linux_2.tar.gz 15309688 BLAKE2B adc315fb29c35b7e16f07ebf9bbd7f8939d92fd5db875f8bd3ed77b8a6d69a895c4be5c94eda571844a01e06f3c594c11a7f08632a259abb7192daffa66bad09 SHA512 91d821fab98a7582d299c9783076e438921621193d87712d676472f588a43a0d6394187f203a939619c8336c45650ec6e9f9f5f45dc4255d56c16f512af98352
diff --git a/app-misc/kryoflux-dtc/kryoflux-dtc-3.50_p2.ebuild b/app-misc/kryoflux-dtc/kryoflux-dtc-3.50_p2.ebuild
new file mode 100644
index 000000000000..17c802cd9e81
--- /dev/null
+++ b/app-misc/kryoflux-dtc/kryoflux-dtc-3.50_p2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+MY_PV_DTC="3.5.0"
+MY_P="kryoflux_${MY_PV}_linux_$(ver_cut 4)"
+MY_P_DTC="${PN}-${MY_PV_DTC}-Linux"
+
+inherit desktop udev wrapper xdg-utils
+
+DESCRIPTION="KryoFlux Host Software"
+HOMEPAGE="https://www.kryoflux.com"
+SRC_URI="https://www.kryoflux.com/download/${MY_P}.tar.gz"
+S="${WORKDIR}/Linux_Release${MY_PV}"
+
+LICENSE="SPS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64"
+IUSE="demos doc gui"
+
+RDEPEND="
+ dev-libs/libfmt
+ virtual/libusb:1
+ gui? ( virtual/jre )
+"
+
+BDEPEND="app-arch/unzip"
+
+DOCS=( "RELEASE.txt" )
+RESTRICT="bindist mirror"
+QA_PREBUILT="
+ usr/lib64/libCAPSImage.so.5.2
+ usr/bin/kryoflux-dtc
+"
+
+src_unpack() {
+ unpack ${A}
+ unpack Linux_Release${MY_PV}/dtc/$(usex amd64 x86_64 aarch64)/${MY_P_DTC}.tar.gz
+ use gui && unpack Linux_Release${MY_PV}/dtc/kryoflux-ui.jar
+}
+
+src_prepare() {
+ default
+
+ # Remove whitespace for demo files
+ pushd testimages
+ mv "G64 (C64)" g64_demo || die
+ mv "IPF (Amiga, Atari ST)" ipf_demo || die
+ popd
+}
+
+src_install() {
+ newbin ../${MY_P_DTC}/bin/dtc kryoflux-dtc
+
+ # We need to use bundled libs instead of 'dev-libs/spsdeclib',
+ # as source code is currently not released.
+ # See https://forum.kryoflux.com/viewtopic.php\?p\=17105
+ dolib.so ../${MY_P_DTC}/lib/libCAPSImage.so.5.2
+
+ insinto /lib/firmware
+ doins ../${MY_P_DTC}/share/dtc/firmware_kf_usb_rosalie.bin
+
+ cat <<-EOF > "${T}"/80-kryoflux.rules || die
+ ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="03eb", ATTR{idProduct}=="6124", GROUP="floppy", MODE="0660"
+ EOF
+ udev_dorules "${T}"/80-kryoflux.rules
+
+ if use gui; then
+ insinto /usr/share/kryoflux-ui
+ doins dtc/kryoflux-ui.jar
+
+ dosym ../../bin/kryoflux-dtc /usr/share/kryoflux-ui/dtc
+ make_wrapper kryoflux-ui "java -jar kryoflux-ui.jar" /usr/share/kryoflux-ui
+
+ newicon ../images/disk.png kryoflux-ui.png
+ make_desktop_entry "kryoflux-ui" "KryoFlux UI" kryoflux-ui Development
+ dodoc dtc/kryoflux-ui_README.txt
+ fi
+
+ if use demos; then
+ pushd testimages
+ dodoc -r g64_demo ipf_demo
+ docompress -x /usr/share/doc/${PF}/g64_demo/BBSB/*.g64
+ docompress -x /usr/share/doc/${PF}/g64_demo/DOTC/*.g64
+ docompress -x /usr/share/doc/${PF}/ipf_demo/*.ipf
+ popd
+ fi
+
+ if use doc; then
+ dodoc -r docs schematics
+ docompress -x /usr/share/doc/${PF}/{docs,schematics}/*.pdf
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you want to access your Kryoflux without root access,"
+ elog "please add yourself to the floppy group."
+
+ udev_reload
+
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ fi
+}