summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Petrina <jakov.petrina@sartura.hr>2021-10-22 15:41:17 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-22 16:23:16 +0200
commit610a6e3c47f0779009aeb7b89beb344845a8ca5e (patch)
tree0ee29491fa58e82b57dcac17378382f499f56db3 /app-misc/jdupes
parentmail-mta/esmtp: drop 1.2-r1 (diff)
downloadgentoo-610a6e3c47f0779009aeb7b89beb344845a8ca5e.tar.gz
gentoo-610a6e3c47f0779009aeb7b89beb344845a8ca5e.tar.bz2
gentoo-610a6e3c47f0779009aeb7b89beb344845a8ca5e.zip
app-misc/jdupes: bump to 1.20.1
Signed-off-by: Jakov Petrina <jakov.petrina@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/22670 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'app-misc/jdupes')
-rw-r--r--app-misc/jdupes/Manifest1
-rw-r--r--app-misc/jdupes/jdupes-1.20.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/jdupes/Manifest b/app-misc/jdupes/Manifest
index d6600033be09..5be5b9f30b27 100644
--- a/app-misc/jdupes/Manifest
+++ b/app-misc/jdupes/Manifest
@@ -1 +1,2 @@
DIST jdupes-1.20.0.tar.gz 93809 BLAKE2B cce6ca06794ee3af9523e3c86550ff2b49a5f42a13278bd61c99099b4c2cab1a392bc973c44593acb23b7e8f99d4f23518f526244182a0d9d3b4084e80cc1015 SHA512 62bb78a902e77f0c9acce93c7c139fc2aaa5911aa85322a372dd0e6b375ee5c4992e91b821fa3f9eb407820657f57591303c9bc14a9fe453d9a4c5651caf05ff
+DIST jdupes-1.20.1.tar.gz 94064 BLAKE2B d2707549a64d51c2c17c418297b631ce26242d31e464848bf13bcd05fe7ec27cde3d3ba4a4b0a0c0b77bf336a7d626aa41ff241f3cdf16cde3d72484df2e55dc SHA512 992ae086b3b13ab001e3367823d8c43645b66a4134ce3211dfaed9c611bc460370e18f1b45905ce57d285174e17ef734b8d597d8d352869f1dc2094c32fcbe93
diff --git a/app-misc/jdupes/jdupes-1.20.1.ebuild b/app-misc/jdupes/jdupes-1.20.1.ebuild
new file mode 100644
index 000000000000..681f1d0f1493
--- /dev/null
+++ b/app-misc/jdupes/jdupes-1.20.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify duplicate files on the filesystem"
+HOMEPAGE="https://github.com/jbruchon/jdupes"
+if [[ "${PV}" == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+# missing test.sh script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/PREFIX/s/=/?=/' Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}