summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/grabcartoons
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/grabcartoons')
-rw-r--r--app-misc/grabcartoons/files/2.8.4-fix-install-paths.patch32
-rw-r--r--app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild35
-rw-r--r--app-misc/grabcartoons/grabcartoons-9999.ebuild35
-rw-r--r--app-misc/grabcartoons/metadata.xml5
4 files changed, 107 insertions, 0 deletions
diff --git a/app-misc/grabcartoons/files/2.8.4-fix-install-paths.patch b/app-misc/grabcartoons/files/2.8.4-fix-install-paths.patch
new file mode 100644
index 000000000000..420640b3de6c
--- /dev/null
+++ b/app-misc/grabcartoons/files/2.8.4-fix-install-paths.patch
@@ -0,0 +1,32 @@
+diff --git a/Makefile b/Makefile
+index a1f53e6..0a9bec4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,9 +23,9 @@ all:
+
+ install:
+ mkdir -p -m 755 $(PREFIX)/bin
+- mkdir -p -m 755 $(PREFIX)/lib/grabcartoons/modules
+- install -m 755 grabcartoons.pl $(PREFIX)/bin
+- install -m 644 modules/*.pl $(PREFIX)/lib/grabcartoons/modules
++ mkdir -p -m 755 $(PREFIX)/share/grabcartoons/modules
++ install -m 755 grabcartoons.pl $(PREFIX)/bin/grabcartoons
++ install -m 644 modules/*.pl $(PREFIX)/share/grabcartoons/modules
+
+ test:
+ ./grabcartoons.pl $(V) "$(C)" > "$(OUT)"
+diff --git a/grabcartoons.pl b/grabcartoons.pl
+index cdc4152..d732301 100755
+--- a/grabcartoons.pl
++++ b/grabcartoons.pl
+@@ -38,8 +38,8 @@ $XTRN_CMD="$XTRN_PROG -q -O- $USER_AGENT_CMD";
+ # Where to load cartoon modules from
+ @MODULE_DIRS=("$FindBin::Bin/modules",
+ "$FindBin::RealBin/modules",
+- "$FindBin::Bin/../lib/grabcartoons/modules",
+- "$FindBin::RealBin/../lib/grabcartoons/modules",
++ "$FindBin::Bin/../share/grabcartoons/modules",
++ "$FindBin::RealBin/../share/grabcartoons/modules",
+ "$HOME/.grabcartoons/modules",
+ "$HOME/.grabcartoons",
+ @GRABCARTOONS_DIRS,
diff --git a/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild b/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild
new file mode 100644
index 000000000000..370741d5813e
--- /dev/null
+++ b/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Comic-summarizing utility"
+HOMEPAGE="http://zzamboni.org/grabcartoons"
+
+EGIT_REPO_URI="https://github.com/zzamboni/grabcartoons.git"
+
+if [[ "${PV}" != "9999" ]] ; then
+ KEYWORDS="~amd64 ~x86"
+ EGIT_COMMIT="cb230f01fb288a0b9f0fc437545b97d06c846bd3"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+# Opens a web page, which is unacceptable during an emerge.
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.8.4-fix-install-paths.patch
+}
+
+src_install() {
+ emake PREFIX="${ED}"/usr install
+ dodoc ChangeLog README
+}
diff --git a/app-misc/grabcartoons/grabcartoons-9999.ebuild b/app-misc/grabcartoons/grabcartoons-9999.ebuild
new file mode 100644
index 000000000000..6917a5f5ee6f
--- /dev/null
+++ b/app-misc/grabcartoons/grabcartoons-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils git-r3
+
+DESCRIPTION="Comic-summarizing utility"
+HOMEPAGE="http://zzamboni.org/grabcartoons"
+
+EGIT_REPO_URI="https://github.com/zzamboni/grabcartoons.git"
+
+if [[ "${PV}" != "9999" ]] ; then
+ KEYWORDS="~amd64 ~x86"
+ #EGIT_COMMIT=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+# Opens a web page, which is unacceptable during an emerge.
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.8.4-fix-install-paths.patch
+}
+
+src_install() {
+ emake PREFIX="${ED}"/usr install
+ dodoc ChangeLog README
+}
diff --git a/app-misc/grabcartoons/metadata.xml b/app-misc/grabcartoons/metadata.xml
new file mode 100644
index 000000000000..effbbf33eac8
--- /dev/null
+++ b/app-misc/grabcartoons/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>