summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-05-24 11:26:19 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-05-24 11:26:29 -0700
commit8611c860bc3b33f55611d61f30e8cbd052a563bb (patch)
tree792092aeeb9cb160aab42f3916debba2dd93e873 /app-misc/check-jsonschema
parentdev-python/regress: new package, add 0.4.5 (diff)
downloadgentoo-8611c860bc3b33f55611d61f30e8cbd052a563bb.tar.gz
gentoo-8611c860bc3b33f55611d61f30e8cbd052a563bb.tar.bz2
gentoo-8611c860bc3b33f55611d61f30e8cbd052a563bb.zip
app-misc/check-jsonschema: add 0.28.4
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/check-jsonschema')
-rw-r--r--app-misc/check-jsonschema/Manifest1
-rw-r--r--app-misc/check-jsonschema/check-jsonschema-0.28.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-misc/check-jsonschema/Manifest b/app-misc/check-jsonschema/Manifest
index d76976b7fc45..d5f1c7620cba 100644
--- a/app-misc/check-jsonschema/Manifest
+++ b/app-misc/check-jsonschema/Manifest
@@ -1,2 +1,3 @@
DIST check-jsonschema-0.21.0.gh.tar.gz 214872 BLAKE2B 0ee013e379523e5a957e745d550c2014872eab9fc3281aad575f92abfada30b7e0853177bd06147b69a81100bf6b987b485342a087830845c32648efc1c7a9a0 SHA512 dd839a9bb104e1fc68e4a7507077dc991dfc9e840f785c4b7024f2838488eb8b8c6a8f7718f0f821981f5b6b23b1d67745948f48db55a0c589395cf43bfdd2a7
DIST check-jsonschema-0.23.3.gh.tar.gz 229537 BLAKE2B a8a40ddc383f38096693a2079b73a8a8fe2ceed5d1e118e539957c205c500807518c0380aa18cae2524efdeda33987f057350ba73b7a699240706ff4e276eafc SHA512 14f9eb6b203e3aec6ca35f75304bd24fd5a09c2b89bcbbf69c22e0c0f44c587972015677498fef1a378683c77f94d9319450daccadddf5fecbe7c738dd16c726
+DIST check-jsonschema-0.28.4.gh.tar.gz 270302 BLAKE2B a5355ed124d6e3bd076403448c3d7fa7c62524c6da49eb5a61d226485639812bdea28b53c570b084e976749b92c1ee586b0285111a543b1a3e8a734ea8d6cc67 SHA512 f4c693ea0951c246814775f26d5c3e5de8020484a92ae15e2a13e284ccb2c58f2bdf7dbdb66612661304f5ff9e6ba88eb3f89e7f0ad23a3f6fc8fcc61372ceea
diff --git a/app-misc/check-jsonschema/check-jsonschema-0.28.4.ebuild b/app-misc/check-jsonschema/check-jsonschema-0.28.4.ebuild
new file mode 100644
index 000000000000..82adc69ea0e5
--- /dev/null
+++ b/app-misc/check-jsonschema/check-jsonschema-0.28.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit optfeature distutils-r1
+
+DESCRIPTION="A CLI and set of pre-commit hooks for jsonschema validation"
+HOMEPAGE="
+ https://pypi.org/project/check-jsonschema/
+ https://github.com/python-jsonschema/check-jsonschema
+"
+SRC_URI="https://github.com/python-jsonschema/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/ruamel-yaml-0.18.6[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.5.1[${PYTHON_USEDEP}]
+ dev-python/regress[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/json5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.25.0[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=(
+ README.md
+ CONTRIBUTING.md
+ CHANGELOG.rst
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/furo
+
+python_prepare_all() {
+ # relax deps in setup.cfg
+ sed -r -e 's:([a-zA-Z.-]+)([<>]|==|[<>]=)+.+:\1: ; /importlib-resources/ d' -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "json5 support" dev-python/json5
+}