summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-03-01 21:33:50 +0800
committerYixun Lan <dlan@gentoo.org>2024-03-08 09:06:22 +0000
commit460e29d4ace2da8af612b3e6e0c593b6f0f937b9 (patch)
tree0a81f82787463b615d0cf0161310c12bf7fb39e9 /app-i18n
parentapp-i18n/fcitx-gtk: add 5.1.2 (diff)
downloadgentoo-460e29d4ace2da8af612b3e6e0c593b6f0f937b9.tar.gz
gentoo-460e29d4ace2da8af612b3e6e0c593b6f0f937b9.tar.bz2
gentoo-460e29d4ace2da8af612b3e6e0c593b6f0f937b9.zip
app-i18n/fcitx-qt: add 5.1.5
Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-qt/Manifest1
-rw-r--r--app-i18n/fcitx-qt/fcitx-qt-5.1.5.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt/Manifest b/app-i18n/fcitx-qt/Manifest
index 414c8e399b34..e7bf43365fcc 100644
--- a/app-i18n/fcitx-qt/Manifest
+++ b/app-i18n/fcitx-qt/Manifest
@@ -1 +1,2 @@
DIST fcitx-qt-5.1.4.tar.xz 92880 BLAKE2B b165740e173fe21e8953b5605713c0250265e4906c25a56c5320f2560d261a9b8d4111f0960287b08fa7ac18c917d0da737fb1022bba7f76ca2e2e00d2d4f060 SHA512 942999327415e3d4195c18c2fb02e12a313e3a2cf1dd1e32d0e6a7a98b625bcc1b3a7278934bb583a029dee43a271dba9bac75face42729249557f60e1146adf
+DIST fcitx-qt-5.1.5.tar.xz 93968 BLAKE2B ce8d0f1d5f92b90500273e5f08efd422a7c3c6734e1472f9b8ce0d87bb1e5309d6cc0b1f6fbff22d061d4ae03db4f434460fd7bc1faf130d097a6742ea3ba810 SHA512 e2c54c942affc457eb1ffc0bbc32b6352a603db12b9c04f723881efb9232a4c348b9b18d9c32373f21790aa8483e72b73acfdfd5b96a61d5010f3ce66e0c5607
diff --git a/app-i18n/fcitx-qt/fcitx-qt-5.1.5.ebuild b/app-i18n/fcitx-qt/fcitx-qt-5.1.5.ebuild
new file mode 100644
index 000000000000..6aef4f82cf22
--- /dev/null
+++ b/app-i18n/fcitx-qt/fcitx-qt-5.1.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-qt"
+
+inherit cmake
+
+DESCRIPTION="Qt library and IM module for fcitx5"
+HOMEPAGE="https://github.com/fcitx/fcitx5-qt"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="BSD LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+qt5 onlyplugin staticplugin qt6 +X wayland"
+REQUIRED_USE="
+ || ( qt5 qt6 )
+ qt5? ( X )
+ staticplugin? ( onlyplugin )
+"
+
+RDEPEND="
+ !onlyplugin? (
+ >=app-i18n/fcitx-5.1.5:5
+ qt5? ( dev-qt/qtconcurrent:5 )
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ wayland? ( dev-qt/qtwayland:5 )
+ )
+ qt6? (
+ dev-qt/qtbase:6[dbus,gui,widgets,wayland?]
+ wayland? ( dev-qt/qtwayland:6 )
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+ !onlyplugin? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT4=no
+ -DENABLE_QT5=$(usex qt5)
+ -DENABLE_QT6=$(usex qt6)
+ -DENABLE_QT6_WAYLAND_WORKAROUND=$(usex qt6 $(usex wayland))
+ -DBUILD_ONLY_PLUGIN=$(usex onlyplugin)
+ -DBUILD_STATIC_PLUGIN=$(usex staticplugin)
+ )
+ cmake_src_configure
+}