summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/imhangul/imhangul-2.0.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/imhangul/imhangul-2.0.0.ebuild')
-rw-r--r--app-i18n/imhangul/imhangul-2.0.0.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/app-i18n/imhangul/imhangul-2.0.0.ebuild b/app-i18n/imhangul/imhangul-2.0.0.ebuild
new file mode 100644
index 000000000000..ccb76bb8681d
--- /dev/null
+++ b/app-i18n/imhangul/imhangul-2.0.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit multilib
+
+DESCRIPTION="Gtk+-2.0 Hangul Input Modules"
+HOMEPAGE="http://kldp.net/projects/imhangul/"
+SRC_URI="http://kldp.net/frs/download.php/5924/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/libhangul-0.0.12
+ >=x11-libs/gtk+-2.2:2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+get_gtk_confdir() {
+ # bug #366889
+ if has_version '>=x11-libs/gtk+-2.22.1-r1:2' || has_multilib_profile ; then
+ GTK2_CONFDIR="${GTK2_CONFDIR:=${EPREFIX}/etc/gtk-2.0/$(get_abi_CHOST)}"
+ else
+ GTK2_CONFDIR="${GTK2_CONFDIR:=${EPREFIX}/etc/gtk-2.0}"
+ fi
+ echo ${GTK2_CONFDIR}
+}
+
+update_gtk_immodules() {
+ local GTK2_CONFDIR=$(get_gtk_confdir)
+
+ mkdir -p "${GTK2_CONFDIR}"
+
+ if [ -x "${EPREFIX}/usr/bin/gtk-query-immodules-2.0" ] ; then
+ "${EPREFIX}/usr/bin/gtk-query-immodules-2.0" > "${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}
+
+src_prepare() {
+ # Drop DEPRECATED flags, bug #387825
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --with-gtk-im-module-dir="${EPREFIX}/usr/$(get_libdir)/gtk-2.0/immodules" \
+ --with-gtk-im-module-file="$(get_gtk_confdir)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ find "${ED}" -name "*.la" -type f -delete || die
+
+ insinto /etc/X11/xinit/xinput.d
+ newins "${FILESDIR}/xinput-imhangul2" imhangul2.conf || die
+ newins "${FILESDIR}/xinput-imhangul2y" imhangul2y.conf || die
+ newins "${FILESDIR}/xinput-imhangul32" imhangul32.conf || die
+ newins "${FILESDIR}/xinput-imhangul39" imhangul39.conf || die
+ newins "${FILESDIR}/xinput-imhangul3f" imhangul3f.conf || die
+ newins "${FILESDIR}/xinput-imhangul3s" imhangul3s.conf || die
+ newins "${FILESDIR}/xinput-imhangul3y" imhangul3y.conf || die
+ newins "${FILESDIR}/xinput-imhangulahn" imhangulahn.conf || die
+ newins "${FILESDIR}/xinput-imhangulro" imhangulro.conf || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO imhangul.conf || die
+}
+
+pkg_postinst() {
+ update_gtk_immodules
+
+ elog ""
+ elog "If you want to use one of the module as a default input method, "
+ elog ""
+ elog "export GTK_IM_MODULE=hangul2 # 2 input type"
+ elog "export GTK_IM_MODULE=hangul3f # 3 input type"
+ elog ""
+}
+
+pkg_postrm() {
+ update_gtk_immodules
+}