summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-21 20:59:35 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-21 17:03:59 -0400
commit5ae1078a706628247d4a35451d61c325fa123c4f (patch)
tree8059e6676dd4597d89a83278d003f9e3206a63ee /app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
parentapp-i18n/fcitx-configtool: Specify slot in dependency on app-i18n/fcitx. (diff)
downloadgentoo-5ae1078a706628247d4a35451d61c325fa123c4f.tar.gz
gentoo-5ae1078a706628247d4a35451d61c325fa123c4f.tar.bz2
gentoo-5ae1078a706628247d4a35451d61c325fa123c4f.zip
app-i18n/fcitx-configtool: Version bump (0.4.10).
Diffstat (limited to 'app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild')
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
new file mode 100644
index 000000000000..28b6f212a5c3
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-configtool"
+fi
+
+DESCRIPTION="GTK+ GUI configuration tool for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-configtool"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK2=OFF
+ -DENABLE_GTK3=ON
+ )
+
+ cmake-utils_src_configure
+}