summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-04-12 11:31:54 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-04-17 11:40:50 -0400
commit96fb4f98f5c23f3454f501efae669f7584f98568 (patch)
treecf99e706be3d9ff9662315021da7caee47302026 /app-eselect
parentmedia-libs/mesa: Version bump to 17.0.4 (diff)
downloadgentoo-96fb4f98f5c23f3454f501efae669f7584f98568.tar.gz
gentoo-96fb4f98f5c23f3454f501efae669f7584f98568.tar.bz2
gentoo-96fb4f98f5c23f3454f501efae669f7584f98568.zip
app-eselect/eselect-postgresql: Bug Fixes and Enhancements
Version 2.0 is capable of handling the upcoming change in versioning for PostgreSQL. Links to pkg-config files of the selected slot are now created and managed by this module. Links to the man pages for the selected slot are now created and managed by this module. Slot-specific man pages are handled by the ebuilds. This version is stateless. It does not need to store any files to determine which slots and links are in use. Bugs: 597564, 512236, 564512 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-postgresql/Manifest1
-rw-r--r--app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-eselect/eselect-postgresql/Manifest b/app-eselect/eselect-postgresql/Manifest
index 923db4ac7045..fab7f53cfe0e 100644
--- a/app-eselect/eselect-postgresql/Manifest
+++ b/app-eselect/eselect-postgresql/Manifest
@@ -1 +1,2 @@
DIST eselect-postgresql-1.2.1.tbz2 3645 SHA256 661ef3cbb1627798af3c8d6c526f4a6367620a5fef08c287a633e1babf43f938 SHA512 9b24cb7620dd3de979ef595c60ebf607cd9da5c7d3c4da19ebe242c25961883e2db54341f916690abb9fe7a76663d9f1ac73fc76c90389f72eff425aa6fb43e4 WHIRLPOOL e7ef4f3d250f4f345d28bccdd43fa1639b8ed80b9f6a4aabd4f7df5f4337845ee0f4ce653fde596209094b01fc0e5c624872affbfa042382f3963a49d600827f
+DIST eselect-postgresql-2.0.tbz2 4326 SHA256 8f56309350f91abaa98eeead42dbd6b186b858f25f207010fe9d10271c754f55 SHA512 bc72d752bc4b2d8f3c255d446253143ff0036f6ca1a0c10eb19e23b8242bd5a912272298034279a6f9ca50c13fccbb6b89c79ed647f762a2ccb36f416060cd87 WHIRLPOOL 9fced29136ee861a78651905329d6a3156bfdbdf61427accc7aa5ac33e934c97e6f673d7a3f5b634d020be01ff0f0533218b8d9d3b83253963f32eae8d82f004
diff --git a/app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild b/app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild
new file mode 100644
index 000000000000..78161c8e52de
--- /dev/null
+++ b/app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Utility to select the default PostgreSQL slot"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~titanofold/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins postgresql.eselect
+
+ dosym /usr/bin/eselect /usr/bin/postgresql-config
+}
+
+pkg_postinst() {
+ postgresql-config update
+}