summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-eselect/eselect-lcdfilter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-eselect/eselect-lcdfilter')
-rw-r--r--app-eselect/eselect-lcdfilter/Manifest2
-rw-r--r--app-eselect/eselect-lcdfilter/eselect-lcdfilter-1.ebuild37
-rw-r--r--app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild36
-rw-r--r--app-eselect/eselect-lcdfilter/metadata.xml11
4 files changed, 86 insertions, 0 deletions
diff --git a/app-eselect/eselect-lcdfilter/Manifest b/app-eselect/eselect-lcdfilter/Manifest
new file mode 100644
index 000000000000..55101f480d9f
--- /dev/null
+++ b/app-eselect/eselect-lcdfilter/Manifest
@@ -0,0 +1,2 @@
+DIST eselect-lcdfilter-1.tar.gz 17206 SHA256 a27229461fff3bc2830a1006ae73d89ce05ba48aef7673c26a2af461457303a4 SHA512 1f86fb2cc21ff9cc9b79c50578a02f7c461ae203533cc817dc733d0dde9ad43763267bb1703b9495ba6f46989e0446bb1cba39aaa705d3b605118f62cb0d2dfc WHIRLPOOL 8bb947e0ddbd6c7056afe9394f37e6520ff0e45536c8572b28690f15fa0c1b699f78db2e7037305e1f0866d67395b67c80c7dd1821a7f2de8c603b2ec037ff2e
+DIST eselect-lcdfilter-2.tar.gz 18365 SHA256 15ea8e85dcc87dec32a5e0a4dcf15251364f8a020cf7d73e858ec46b5590b6a0 SHA512 e17c475c860f0a3ad7249d21ca11c52f3226852ba042b83058baf6823242c4f8be0042aad52029757944fce6d816df386b928f2005ab87e0778d3ecb26ceec92 WHIRLPOOL d20a5d97386753a3d5fc01b91fa18ddc9b3106900268fe27bdf8f21ef1c9cf788dcde8c9714cbc52142e79b5f02dd8657dfef652c45658dc76d70da3b22739e6
diff --git a/app-eselect/eselect-lcdfilter/eselect-lcdfilter-1.ebuild b/app-eselect/eselect-lcdfilter/eselect-lcdfilter-1.ebuild
new file mode 100644
index 000000000000..045e82de8936
--- /dev/null
+++ b/app-eselect/eselect-lcdfilter/eselect-lcdfilter-1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit vcs-snapshot
+
+DESCRIPTION="Eselect module to choose Freetype infinality-enhanced LCD filtering settings"
+HOMEPAGE="https://github.com/yngwin/eselect-lcdfilter"
+SRC_URI="${HOMEPAGE}/tarball/v1 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-admin/eselect"
+PDEPEND="media-libs/freetype[infinality]"
+
+src_install() {
+ dodoc README.rst infinality-settings.sh
+
+ insinto "/usr/share/eselect/modules"
+ doins lcdfilter.eselect
+
+ insinto "/usr/share/${PN}"
+ doins -r env.d
+}
+
+pkg_postinst() {
+ elog "Use eselect lcdfilter to select an lcdfiltering font style."
+ elog "You can customize /usr/share/${PN}/env.d/custom"
+ elog "with your own settings. See /usr/share/doc/${PF}/infinality-settings.sh"
+ elog "for an explanation and examples of the variables."
+ elog "This module is supposed to be used in pair with eselect infinality."
+}
diff --git a/app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild b/app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild
new file mode 100644
index 000000000000..dcc1fa7e7701
--- /dev/null
+++ b/app-eselect/eselect-lcdfilter/eselect-lcdfilter-2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vcs-snapshot readme.gentoo
+
+DESCRIPTION="Eselect module to choose Freetype infinality-enhanced LCD filtering settings"
+HOMEPAGE="https://github.com/yngwin/eselect-lcdfilter"
+SRC_URI="${HOMEPAGE}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-admin/eselect"
+PDEPEND="media-libs/freetype[infinality]"
+
+src_install() {
+ DOC_CONTENTS="Use eselect lcdfilter to select an lcdfiltering font style.
+ You can customize ${EPREFIX}/usr/share/${PN}/env.d/custom with your own settings.
+ See ${EPREFIX}/usr/share/doc/${PF}/infinality-settings.sh for an explanation and
+ examples of the variables. This module is supposed to be used in pair with
+ eselect infinality."
+
+ dodoc README.rst infinality-settings.sh
+ readme.gentoo_create_doc
+
+ insinto "/usr/share/eselect/modules"
+ doins lcdfilter.eselect
+
+ insinto "/usr/share/${PN}"
+ doins -r env.d
+}
diff --git a/app-eselect/eselect-lcdfilter/metadata.xml b/app-eselect/eselect-lcdfilter/metadata.xml
new file mode 100644
index 000000000000..bb17f15c3812
--- /dev/null
+++ b/app-eselect/eselect-lcdfilter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ </maintainer>
+ <herd>fonts</herd>
+ <upstream>
+ <remote-id type="github">yngwin/eselect-lcdfilter</remote-id>
+ </upstream>
+</pkgmetadata>