summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-04-22 00:44:44 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-04-22 00:48:04 -0700
commita86d23a290bba9f7c9135c181579c350086f2599 (patch)
treef0b4f2cbe56b1fd40f3299d04716f0c65674c31e /app-emulation
parentdev-python/hacking: Bump to 4.1.0 (diff)
downloadgentoo-a86d23a290bba9f7c9135c181579c350086f2599.tar.gz
gentoo-a86d23a290bba9f7c9135c181579c350086f2599.tar.bz2
gentoo-a86d23a290bba9f7c9135c181579c350086f2599.zip
app-emulation/docker: add /dev/null patch to 20.10.6
Bug: https://bugs.gentoo.org/748984 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker/docker-20.10.6-r1.ebuild (renamed from app-emulation/docker/docker-20.10.6.ebuild)7
-rw-r--r--app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch28
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/docker/docker-20.10.6.ebuild b/app-emulation/docker/docker-20.10.6-r1.ebuild
index ac40f8d73289..50015f97773f 100644
--- a/app-emulation/docker/docker-20.10.6.ebuild
+++ b/app-emulation/docker/docker-20.10.6-r1.ebuild
@@ -158,6 +158,13 @@ pkg_setup() {
linux-info_pkg_setup
}
+src_prepare() {
+ default
+ pushd "${S}/vendor/github.com/coreos/etcd" >/dev/null || die
+ eapply "${FILESDIR}/etcd-F_OFD_GETLK-fix.patch"
+ popd >/dev/null || die
+}
+
src_compile() {
export DOCKER_GITCOMMIT="${GIT_COMMIT}"
export GOPATH="${WORKDIR}/${P}"
diff --git a/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch b/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch
new file mode 100644
index 000000000000..d912e59e985b
--- /dev/null
+++ b/app-emulation/docker/files/etcd-F_OFD_GETLK-fix.patch
@@ -0,0 +1,28 @@
+From ec81adb21605acd56b122bc35c53644b13d3ab7e Mon Sep 17 00:00:00 2001
+From: Moritz Both <mb@aldebaran.de>
+Date: Sun, 1 Nov 2020 23:20:12 +0100
+Subject: [PATCH] pkg/fileutil: fix constant for linux locking
+
+The constant F_OFD_GETLK is 36, not 37, according to
+/usr/include/bits/fcntl-linux.h
+Credits go to joakim-tjernlund who digged deep enough
+to find this.
+
+Fixes #31182
+---
+ pkg/fileutil/lock_linux.go | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pkg/fileutil/lock_linux.go b/pkg/fileutil/lock_linux.go
+index 939fea62381..004d35fa23b 100644
+--- a/pkg/fileutil/lock_linux.go
++++ b/pkg/fileutil/lock_linux.go
+@@ -29,7 +29,7 @@ import (
+ //
+ // constants from /usr/include/bits/fcntl-linux.h
+ const (
+- F_OFD_GETLK = 37
++ F_OFD_GETLK = 36
+ F_OFD_SETLK = 37
+ F_OFD_SETLKW = 38
+ )