summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-29 18:15:27 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-29 18:46:14 -0400
commita90eb4fee647a41dec33f3c50e7d6ef531d1ffed (patch)
tree346fa9d26e2bef147d259e1edd68f5c785e58ed4 /app-emulation/ruffle
parentapp-emulation/ruffle: drop 0_p20240722 (diff)
downloadgentoo-a90eb4fee647a41dec33f3c50e7d6ef531d1ffed.tar.gz
gentoo-a90eb4fee647a41dec33f3c50e7d6ef531d1ffed.tar.bz2
gentoo-a90eb4fee647a41dec33f3c50e7d6ef531d1ffed.zip
app-emulation/ruffle: update live
Switch to a copyable style live ebuild plus vendored crates for the next release. Also bump rust minimum to 1.81 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/ruffle')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild43
1 files changed, 36 insertions, 7 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 457bc5e52efc..fbb6ac59d57f 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -3,16 +3,30 @@
EAPI=8
-inherit cargo desktop git-r3 optfeature xdg
+inherit cargo desktop optfeature xdg
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://code.videolan.org/videolan/libplacebo.git"
+ inherit git-r3
+else
+ MY_PV=nightly-${PV:3:4}-${PV:7:2}-${PV:9:2}
+ MY_P=${PN}-${MY_PV}
+ SRC_URI="
+ https://github.com/ruffle-rs/ruffle/archive/refs/tags/${MY_PV}.tar.gz
+ -> ${MY_P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${MY_P}-vendor.tar.xz
+ "
+ S=${WORKDIR}/${MY_P}
+ KEYWORDS="~amd64"
+fi
DESCRIPTION="Flash Player emulator written in Rust"
HOMEPAGE="https://ruffle.rs/"
-EGIT_REPO_URI="https://github.com/ruffle-rs/ruffle.git"
LICENSE="|| ( Apache-2.0 MIT )"
LICENSE+="
- Apache-2.0 BSD-2 BSD Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 openssl
- Unicode-DFS-2016 ZLIB
+ Apache-2.0 BSD-2 BSD Boost-1.0 CC0-1.0 ISC UbuntuFontLicense-1.0 MIT
+ MPL-2.0 OFL-1.1 openssl Unicode-3.0 Unicode-DFS-2016 ZLIB
" # crates
SLOT="0"
IUSE="test"
@@ -34,7 +48,7 @@ DEPEND="
BDEPEND="
virtual/jre:*
virtual/pkgconfig
- >=virtual/rust-1.77
+ >=virtual/rust-1.81
"
QA_FLAGS_IGNORED="usr/bin/${PN}.*"
@@ -44,8 +58,12 @@ PATCHES=(
)
src_unpack() {
- git-r3_src_unpack
- cargo_live_src_unpack
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cargo_live_src_unpack
+ else
+ cargo_src_unpack
+ fi
}
src_configure() {
@@ -84,5 +102,16 @@ src_install() {
pkg_postinst() {
xdg_pkg_postinst
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "${PN} is experimental software that is still under heavy development"
+ elog "and only receiving nightly releases. Plans in Gentoo is to update"
+ elog "roughly every months if no known major regressions (feel free to"
+ elog "report if you feel a newer nightly is needed ahead of time)."
+ elog
+ elog "There is currently no plans to support wasm builds / browser"
+ elog "extensions, this provides the desktop viewer and other tools."
+ fi
+
+ optfeature "h264 video decoding" media-libs/openh264
optfeature "the in-application file picker" sys-apps/xdg-desktop-portal
}