summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-09-06 19:34:10 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-09-06 19:34:10 +0200
commitc7d538df1946db129af66d349da31ad8942cd331 (patch)
treece08bf7066f5fcd5ae346cbc7c13f84cf372d5f1 /app-emulation/img
parentapp-emulation/reg: Version bump to 0.15.5 (diff)
downloadgentoo-c7d538df1946db129af66d349da31ad8942cd331.tar.gz
gentoo-c7d538df1946db129af66d349da31ad8942cd331.tar.bz2
gentoo-c7d538df1946db129af66d349da31ad8942cd331.zip
app-emulation/img: Version bump to 0.4.9
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-emulation/img')
-rw-r--r--app-emulation/img/Manifest1
-rw-r--r--app-emulation/img/img-0.4.9.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
index a8c702de029a..ba80778bcbd6 100644
--- a/app-emulation/img/Manifest
+++ b/app-emulation/img/Manifest
@@ -1 +1,2 @@
DIST img-0.4.8.tar.gz 5587652 BLAKE2B 5b74ff24e6f36674b66b3f87abe928a9d8c8361835eb61cb04ddfce6bfc7cb7b8e6e1f41d61d9f75c09c3646d0d697074882e1f7b87259b60d7c53303718e325 SHA512 fb5b97c4794798dc2dba5d4c9493da9708a55a9e5e7b2259585409c4e7973fecd362132dabb81c72f20b61956c5a8bc67b58db49c22e7ce56eaec784bbb51ca5
+DIST img-0.4.9.tar.gz 4654821 BLAKE2B b3cd419aeb64ec8c2e8ee0fd523d387fd5b1a340ad61deec1e3fda59ba4e58e7594682aa49e04922e5bdcad4c458f23d4b8081784ba9d7d88dc953a0bd7c24a9 SHA512 c529affce023a8ae972a8526b48701d137edd3a8d5a22687269eec07864a1c30edf1c84bfea29cb7d166cc4fed4b0eb1e34e41d5d21be9d1a3b975b4c1bc678f
diff --git a/app-emulation/img/img-0.4.9.ebuild b/app-emulation/img/img-0.4.9.ebuild
new file mode 100644
index 000000000000..24dc44fe9cb3
--- /dev/null
+++ b/app-emulation/img/img-0.4.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="0060d887c61df8002cb05225f380cae6a8798f9a"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}