summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-25 16:29:57 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-25 16:29:57 -0700
commit950ad9503edeca6aaa690e6a6e062e3ce08bbd61 (patch)
tree3b37a3226a4e149117fc8c2b1f2eb0a6478e1b7b /app-emulation/containerd
parentapp-emulation/containerd: work around makefile race condition (diff)
downloadgentoo-950ad9503edeca6aaa690e6a6e062e3ce08bbd61.tar.gz
gentoo-950ad9503edeca6aaa690e6a6e062e3ce08bbd61.tar.bz2
gentoo-950ad9503edeca6aaa690e6a6e062e3ce08bbd61.zip
app-emulation/containerd: apply #nowarn properly to -j1
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/containerd-1.3.7.ebuild3
-rw-r--r--app-emulation/containerd/containerd-1.3.9.ebuild3
-rw-r--r--app-emulation/containerd/containerd-1.4.4.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/app-emulation/containerd/containerd-1.3.7.ebuild b/app-emulation/containerd/containerd-1.3.7.ebuild
index de9c94b35575..b78f87e7f3d6 100644
--- a/app-emulation/containerd/containerd-1.3.7.ebuild
+++ b/app-emulation/containerd/containerd-1.3.7.ebuild
@@ -66,7 +66,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
export GOFLAGS="-v -x -mod=vendor"
- emake "${myemakeargs[@]}" man -j1 #nowarn https://bugs.gentoo.org/765100
+ # race condition in man target https://bugs.gentoo.org/765100
+ emake "${myemakeargs[@]}" man -j1 #nowarn
emake "${myemakeargs[@]}" all
}
diff --git a/app-emulation/containerd/containerd-1.3.9.ebuild b/app-emulation/containerd/containerd-1.3.9.ebuild
index ce0733b1086a..2e7c01ad5a79 100644
--- a/app-emulation/containerd/containerd-1.3.9.ebuild
+++ b/app-emulation/containerd/containerd-1.3.9.ebuild
@@ -66,7 +66,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
export GOFLAGS="-v -x -mod=vendor"
- emake "${myemakeargs[@]}" man -j1 #nowarn https://bugs.gentoo.org/765100
+ # race condition in man target https://bugs.gentoo.org/765100
+ emake "${myemakeargs[@]}" man -j1 #nowarn
emake "${myemakeargs[@]}" all
}
diff --git a/app-emulation/containerd/containerd-1.4.4.ebuild b/app-emulation/containerd/containerd-1.4.4.ebuild
index 18c54a20724a..f63187003559 100644
--- a/app-emulation/containerd/containerd-1.4.4.ebuild
+++ b/app-emulation/containerd/containerd-1.4.4.ebuild
@@ -63,7 +63,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
export GOFLAGS="-v -x -mod=vendor"
- emake "${myemakeargs[@]}" man -j1 #nowarn https://bugs.gentoo.org/765100
+ # race condition in man target https://bugs.gentoo.org/765100
+ emake "${myemakeargs[@]}" man -j1 #nowarn
emake "${myemakeargs[@]}" all
}