summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-12 12:19:34 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-12 12:19:34 +0100
commit94946563ed29860ac4a70201b7fbdc516b934365 (patch)
tree55611836d5f04380a6e58c38ea70ff915b131143 /app-emacs
parentsys-kernel/gentoo-sources: Linux 6.1 and genpatches (diff)
downloadgentoo-94946563ed29860ac4a70201b7fbdc516b934365.tar.gz
gentoo-94946563ed29860ac4a70201b7fbdc516b934365.tar.bz2
gentoo-94946563ed29860ac4a70201b7fbdc516b934365.zip
app-emacs/sesman: new package; add 0.3.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/sesman/Manifest1
-rw-r--r--app-emacs/sesman/files/50sesman-gentoo.el5
-rw-r--r--app-emacs/sesman/metadata.xml25
-rw-r--r--app-emacs/sesman/sesman-0.3.4.ebuild30
4 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/sesman/Manifest b/app-emacs/sesman/Manifest
new file mode 100644
index 000000000000..33c5f021ded8
--- /dev/null
+++ b/app-emacs/sesman/Manifest
@@ -0,0 +1 @@
+DIST sesman-0.3.4.tar.gz 18256 BLAKE2B 3d7eca5bb5df1778053cf9e37a9d02f16fd98e3c42163c19ae8bf04815ed7e1a7e17b5a050ad5b3f7258764c0a2d71c06de820b6023df100e4a2d3aa263ced2d SHA512 e9478ca4a3cbe1cc357b983c14d94fbe20b95cc8ac1789136700016ce749febcbf3ce28879e9fc02373fbf1a828c0786b35a6e808baf8a607aa34292838a49bf
diff --git a/app-emacs/sesman/files/50sesman-gentoo.el b/app-emacs/sesman/files/50sesman-gentoo.el
new file mode 100644
index 000000000000..fa3dffc96c2e
--- /dev/null
+++ b/app-emacs/sesman/files/50sesman-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'sesman-browser "sesman-browser"
+ "Display an interactive session browser." t)
+(autoload 'sesman-start "sesman"
+ "Start a Sesman session." t)
diff --git a/app-emacs/sesman/metadata.xml b/app-emacs/sesman/metadata.xml
new file mode 100644
index 000000000000..017fcd7db750
--- /dev/null
+++ b/app-emacs/sesman/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Sesman provides facilities for session management and interactive session
+ association with the current contexts (e.g. project, directory, buffers).
+ While sesman can be used to manage arbitrary "sessions", it primary targets
+ the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.) For Emacs based
+ IDEs, session are commonly composed of one or more physical processes
+ (sub-processes, sockets, websockets etc). For example in the current
+ implementation of CIDER a session would be composed of one or more sesman
+ connections (Clojure or ClojureScript). Each CIDER connection consists of
+ user REPL buffer and two sub-processes, one for user eval communication and
+ another for tooling (completion, inspector etc).
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/vspinu/sesman/issues/</bugs-to>
+ <remote-id type="github">vspinu/sesman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/sesman/sesman-0.3.4.ebuild b/app-emacs/sesman/sesman-0.3.4.ebuild
new file mode 100644
index 000000000000..2018a07a9f2b
--- /dev/null
+++ b/app-emacs/sesman/sesman-0.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Generic session manager for Emacs based IDEs"
+HOMEPAGE="https://github.com/vspinu/sesman/"
+SRC_URI="https://github.com/vspinu/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l ${PN}-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}
+
+src_install() {
+ rm sesman-test.el* || die
+
+ elisp_src_install
+}