summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-10 21:20:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-10 21:24:19 +0200
commit0121d2c800168184476c16ff049ac394887b4f86 (patch)
tree27a0181883c8ce4c0da5440fbf5dc1caeb9c36d2 /app-emacs
parentsys-apps/diffutils: drop 'static' USE flag (diff)
downloadgentoo-0121d2c800168184476c16ff049ac394887b4f86.tar.gz
gentoo-0121d2c800168184476c16ff049ac394887b4f86.tar.bz2
gentoo-0121d2c800168184476c16ff049ac394887b4f86.zip
app-emacs/treemacs-all-the-icons: new package; add 3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/treemacs-all-the-icons/Manifest1
-rw-r--r--app-emacs/treemacs-all-the-icons/files/50treemacs-all-the-icons-gentoo.el1
-rw-r--r--app-emacs/treemacs-all-the-icons/metadata.xml13
-rw-r--r--app-emacs/treemacs-all-the-icons/treemacs-all-the-icons-3.1.ebuild35
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/treemacs-all-the-icons/Manifest b/app-emacs/treemacs-all-the-icons/Manifest
new file mode 100644
index 000000000000..58c616d904f5
--- /dev/null
+++ b/app-emacs/treemacs-all-the-icons/Manifest
@@ -0,0 +1 @@
+DIST treemacs-3.1.tar.gz 4562915 BLAKE2B b728c6ea795fe1159c2342b593cc4e6b3d06a1ba58dca876e5472e394b77a3a9930740aa9ecb65973f551322018920f08b0b49e897d5677b7a0f1da42cfad2d3 SHA512 e891cfa68916ecc250ab0446a4eb0149deea17a7f366870ce757e73f175bc823dae87080a584ea315d502c50559d030055f2f399cbd92d40af8c2dca5308604c
diff --git a/app-emacs/treemacs-all-the-icons/files/50treemacs-all-the-icons-gentoo.el b/app-emacs/treemacs-all-the-icons/files/50treemacs-all-the-icons-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/treemacs-all-the-icons/files/50treemacs-all-the-icons-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/treemacs-all-the-icons/metadata.xml b/app-emacs/treemacs-all-the-icons/metadata.xml
new file mode 100644
index 000000000000..2b59c18813b9
--- /dev/null
+++ b/app-emacs/treemacs-all-the-icons/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Alexander-Miller/treemacs/issues/</bugs-to>
+ <remote-id type="github">Alexander-Miller/treemacs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/treemacs-all-the-icons/treemacs-all-the-icons-3.1.ebuild b/app-emacs/treemacs-all-the-icons/treemacs-all-the-icons-3.1.ebuild
new file mode 100644
index 000000000000..be9aa60e9006
--- /dev/null
+++ b/app-emacs/treemacs-all-the-icons/treemacs-all-the-icons-3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs all-the-icons integration for treemacs"
+HOMEPAGE="https://github.com/Alexander-Miller/treemacs/"
+SRC_URI="https://github.com/Alexander-Miller/treemacs/archive/${PV}.tar.gz
+ -> treemacs-${PV}.tar.gz"
+S="${WORKDIR}"/treemacs-${PV}/src/extra
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/all-the-icons
+ app-emacs/treemacs
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}