summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/lyskom-elisp-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/lyskom-elisp-client')
-rw-r--r--app-emacs/lyskom-elisp-client/Manifest1
-rw-r--r--app-emacs/lyskom-elisp-client/files/50lyskom-elisp-client-gentoo.el2
-rw-r--r--app-emacs/lyskom-elisp-client/lyskom-elisp-client-0.48_p20131231.ebuild38
-rw-r--r--app-emacs/lyskom-elisp-client/metadata.xml5
4 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/lyskom-elisp-client/Manifest b/app-emacs/lyskom-elisp-client/Manifest
new file mode 100644
index 000000000000..33ecc18bf4aa
--- /dev/null
+++ b/app-emacs/lyskom-elisp-client/Manifest
@@ -0,0 +1 @@
+DIST lyskom-elisp-client-0.48_p20131231.tar.xz 888212 SHA256 d34ebefc299942ae3990f4d309ae17bef847b5e546482bbfe6b5cdd78a0c55b7 SHA512 124dc45194d68588535e134acae9de9b19484b568c43d2eb49d3c4e8ee923e0baf64a634181a3238f34cf59a98a5a1e92e988519d26e8f3c3a0e867f500d53e9 WHIRLPOOL f13addd5561a86f257def968b5a7d73433e1d53bde0452dcc6bbfe41381eb977fa1da398eac05da1c113c8c82c59a4db2c62ba4825fb83db1f548bdb54dc6f04
diff --git a/app-emacs/lyskom-elisp-client/files/50lyskom-elisp-client-gentoo.el b/app-emacs/lyskom-elisp-client/files/50lyskom-elisp-client-gentoo.el
new file mode 100644
index 000000000000..8625986f64b6
--- /dev/null
+++ b/app-emacs/lyskom-elisp-client/files/50lyskom-elisp-client-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'lyskom "lyskom" "Start LysKOM" t)
diff --git a/app-emacs/lyskom-elisp-client/lyskom-elisp-client-0.48_p20131231.ebuild b/app-emacs/lyskom-elisp-client/lyskom-elisp-client-0.48_p20131231.ebuild
new file mode 100644
index 000000000000..5b8f272374ca
--- /dev/null
+++ b/app-emacs/lyskom-elisp-client/lyskom-elisp-client-0.48_p20131231.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Elisp client for the LysKOM conference system"
+HOMEPAGE="http://www.lysator.liu.se/lyskom/klienter/emacslisp/index.en.html"
+# snapshot of git://git.lysator.liu.se/${PN}/${PN}.git
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE="linguas_sv"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake -C src EMACS=emacs
+ # Info page is in Swedish only
+ use linguas_sv && emake -C doc elisp-client
+}
+
+src_install() {
+ elisp-install ${PN} src/lyskom.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc src/{ChangeLog*,README,TODO} doc/NEWS*
+ use linguas_sv && doinfo doc/elisp-client
+
+ DOC_CONTENTS="If you prefer an English language environment, add the
+ following line to your ~/.emacs file:
+ \n\t(setq-default kom-default-language 'en)"
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/lyskom-elisp-client/metadata.xml b/app-emacs/lyskom-elisp-client/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/lyskom-elisp-client/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>