summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-12-15 16:53:08 +0100
committerUlrich Müller <ulm@gentoo.org>2023-12-15 17:00:10 +0100
commita855c73304ff69dcf908c9acc1f5d26654db1f9f (patch)
treefcc8aeef529ccc27d95c27931cdcb4aa8acddec3 /app-emacs/flim
parentapp-emacs/oauth2: new package, add 0.16 (diff)
downloadgentoo-a855c73304ff69dcf908c9acc1f5d26654db1f9f.tar.gz
gentoo-a855c73304ff69dcf908c9acc1f5d26654db1f9f.tar.bz2
gentoo-a855c73304ff69dcf908c9acc1f5d26654db1f9f.zip
app-emacs/flim: Add conditional dependency on app-emacs/oauth2
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/flim')
-rw-r--r--app-emacs/flim/flim-1.14.9_p20231214-r1.ebuild49
-rw-r--r--app-emacs/flim/metadata.xml5
2 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/flim/flim-1.14.9_p20231214-r1.ebuild b/app-emacs/flim/flim-1.14.9_p20231214-r1.ebuild
new file mode 100644
index 000000000000..74e525fda945
--- /dev/null
+++ b/app-emacs/flim/flim-1.14.9_p20231214-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A library to provide basic features about message representation or encoding"
+HOMEPAGE="https://github.com/wanderlust/flim"
+GITHUB_SHA1="c430c5498ad5843f40ef758685e29431f167478c"
+SRC_URI="https://github.com/wanderlust/${PN}/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="oauth2 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-emacs/apel-10.8
+ oauth2? ( app-emacs/oauth2 )"
+
+BDEPEND="${RDEPEND}
+ test? ( app-emacs/oauth2 )"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+ sed -i "s/(module-installed-p 'oauth2)/$(usex oauth2 t nil)/" \
+ FLIM-ELS || die
+}
+
+src_compile() {
+ emake PACKAGE_LISPDIR="NONE"
+}
+
+src_test() {
+ emake PACKAGE_LISPDIR="NONE" check
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ PACKAGE_LISPDIR="NONE" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" install
+ elisp-make-site-file "${SITEFILE}"
+ dodoc FLIM-API.en NEWS VERSION README* ChangeLog*
+}
diff --git a/app-emacs/flim/metadata.xml b/app-emacs/flim/metadata.xml
index 0c64d614fe2d..735e0535fd3d 100644
--- a/app-emacs/flim/metadata.xml
+++ b/app-emacs/flim/metadata.xml
@@ -6,6 +6,11 @@
<name>Gentoo GNU Emacs project</name>
</maintainer>
<stabilize-allarches/>
+<use>
+ <flag name="oauth2">
+ Support OAuth2 authentication (<pkg>app-emacs/oauth2</pkg>)
+ </flag>
+</use>
<upstream>
<remote-id type="github">wanderlust/flim</remote-id>
</upstream>