summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-22 00:48:21 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-22 15:09:43 +0200
commit80c60a766820119c7244e2d2595658b087a10794 (patch)
tree8605cba3dd54facf46a79607cc147b0f637594fd /app-emacs/eldev
parentapp-emacs/eldev: drop old 1.4 (diff)
downloadgentoo-80c60a766820119c7244e2d2595658b087a10794.tar.gz
gentoo-80c60a766820119c7244e2d2595658b087a10794.tar.bz2
gentoo-80c60a766820119c7244e2d2595658b087a10794.zip
app-emacs/eldev: bump to 1.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/eldev')
-rw-r--r--app-emacs/eldev/Manifest1
-rw-r--r--app-emacs/eldev/eldev-1.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/eldev/Manifest b/app-emacs/eldev/Manifest
index 333ec482e125..696bc894b727 100644
--- a/app-emacs/eldev/Manifest
+++ b/app-emacs/eldev/Manifest
@@ -1 +1,2 @@
DIST eldev-1.4.1.tar.gz 268814 BLAKE2B d31ef7842888f523dab25d279064ceda2f427f70f3353d015485bc78346f368e2a56f1a5dfc0243efae36752576be32b869726e391b040eda9c3ea4418002d67 SHA512 485ccbdbcb40c3e2a19de5bad7b35bc439a4fe7c228c28ca0c75ca8292ff6216bbf78bb2d26678b94b9fcc5526aea12e1e9c6aa0368e343a08c9081ef1058e81
+DIST eldev-1.5.tar.gz 276909 BLAKE2B 963940d203c0864d091c50703d18805b48e3bcc4d4fec07262421c453ad346a3963d711b2a96f10e46c2329ba75f6a92093ec2845726e83958e6973a8d579b0a SHA512 fcb277175254de51b37caab04ba74422925b22d3bc98e9e84a2f563f3251fa2bfabb573c98800a05245713d256fbdb59d1091d94a037ddb3a7dda4879f451e88
diff --git a/app-emacs/eldev/eldev-1.5.ebuild b/app-emacs/eldev/eldev-1.5.ebuild
new file mode 100644
index 000000000000..d4cf84d1ef57
--- /dev/null
+++ b/app-emacs/eldev/eldev-1.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp Development Tool"
+HOMEPAGE="https://github.com/doublep/eldev/"
+SRC_URI="https://github.com/doublep/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~arm ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+DOCS=( README.adoc )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ELDEV_LOCAL="${S}" ./bin/${PN} test
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+
+ # NOTICE: If ELDEV_LOCAL is defined Eldev will use it
+ # to load up it's components,
+ # if it is not it will bootstrap itself from network
+ # always check if it uses installed Emacs Lisp files.
+ # Also, do not forget to run `env-update` & reopen your shell.
+ # https://github.com/doublep/eldev#influential-environment-variables
+ echo "ELDEV_LOCAL=${SITELISP}/${PN}" >> "${T}"/99${PN} || die
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use Eldev in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}