summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-15 17:08:47 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-16 00:59:52 +0200
commitc548f829f3c9b2510ef9f3107ac19981c9851f2d (patch)
tree837b5b1099198bba20fc5b60abab2719133fb6e9 /app-editors
parentx11-libs/gtef: initial ebuild (diff)
downloadgentoo-c548f829f3c9b2510ef9f3107ac19981c9851f2d.tar.gz
gentoo-c548f829f3c9b2510ef9f3107ac19981c9851f2d.tar.bz2
gentoo-c548f829f3c9b2510ef9f3107ac19981c9851f2d.zip
app-editors/latexila: version bump 3.22.1 → 3.24.2
Package-Manager: Portage-2.3.7, Repoman-2.3.3 RepoMan-Options: --force
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/latexila/Manifest1
-rw-r--r--app-editors/latexila/latexila-3.24.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-editors/latexila/Manifest b/app-editors/latexila/Manifest
index 354252a094d4..92ad27bf3e26 100644
--- a/app-editors/latexila/Manifest
+++ b/app-editors/latexila/Manifest
@@ -1 +1,2 @@
DIST latexila-3.22.1.tar.xz 1111820 SHA256 41692d850a48521d2a700ae296680464078ef0bef1c1383383b433c5ecdf2719 SHA512 7c2d3b95b9547e97c79f5e6384b1f33ccb81e70cea1d26fcc07845f3f391ac54b5931ddcec742f3439ba55e8f9f2a2054935795ab16bee584eb05780a72ba3a9 WHIRLPOOL bacdd353a29c79612bc7f9b786b9c9ff5c4d12bf595b6795eb498251d724be7a29915723e2a0d29ef8bef22b096259da540e8b11d5e6ac4287833abfbc306a9f
+DIST latexila-3.24.2.tar.xz 1120940 SHA256 89042a9253b3e150d56bada649d47a9879fd702fc46f73be5649b0edad3f1183 SHA512 8facaa57a87b58ba3aeffcd1c59e2770fe8e95bdbf0cd2e5fa39554c1eba3ba93aa4cb544fd09564cc9481d919a0b04d46169d053f9f155deaa8826050a4c72c WHIRLPOOL 97ed80c4bdde8ecae830e898e7d3cf90d8d8c923277dbeb6d2b0471f6178b5a8f80133521206093003d36aa4dd1c1ce6063367491e1d407e247c90d7ae72002e
diff --git a/app-editors/latexila/latexila-3.24.2.ebuild b/app-editors/latexila/latexila-3.24.2.ebuild
new file mode 100644
index 000000000000..d95cfae59a3f
--- /dev/null
+++ b/app-editors/latexila/latexila-3.24.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.34"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/LaTeXila"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection +latexmk rubber"
+
+COMMON_DEPEND="
+ $(vala_depend)
+ app-text/enchant
+ >=app-text/gspell-1.0:0=
+ >=dev-libs/glib-2.50:2[dbus]
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtef-2.0
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/gtksourceview-3.24:3.0=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection)
+}