summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-05 01:37:10 +0100
committerSam James <sam@gentoo.org>2022-07-05 01:37:10 +0100
commit3601fb65d0a06dbd5f19820609461085532ef9a3 (patch)
tree3d17ab260aef0e54cd5d1356b303fd9298da8ed9 /app-editors
parentapp-editors/neovim: rebase Darwin patch (diff)
downloadgentoo-3601fb65d0a06dbd5f19820609461085532ef9a3.tar.gz
gentoo-3601fb65d0a06dbd5f19820609461085532ef9a3.tar.bz2
gentoo-3601fb65d0a06dbd5f19820609461085532ef9a3.zip
app-editors/neovim: backport Darwin patch to 0.7.2
Closes: https://github.com/gentoo/gentoo/pull/25889 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch55
-rw-r--r--app-editors/neovim/neovim-0.7.2.ebuild1
-rw-r--r--app-editors/neovim/neovim-9999.ebuild2
3 files changed, 57 insertions, 1 deletions
diff --git a/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch
new file mode 100644
index 000000000000..a8404bd4a97a
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch
@@ -0,0 +1,55 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -80,23 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
+ # used for check_c_compiler_flag
+ include(CheckCCompilerFlag)
+
+-if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+- # CMake tries to treat /sw and /opt/local as extension of the system path, but
+- # that doesn't really work out very well. Once you have a dependency that
+- # resides there and have to add it as an include directory, then any other
+- # dependency that could be satisfied from there must be--otherwise you can end
+- # up with conflicting versions. So, let's make them more of a priority having
+- # them be included as one of the first places to look for dependencies.
+- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
+-
+- # Work around some old, broken detection by CMake for knowing when to use the
+- # isystem flag. Apple's compilers have supported this for quite some time
+- # now.
+- if(CMAKE_COMPILER_IS_GNUCC)
+- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
+- endif()
+-endif()
+-
+ if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ # Ignore case when comparing filenames on Windows and Mac.
+ set(CASE_INSENSITIVE_FILENAME TRUE)
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
+@@ -205,10 +205,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
+ foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
+ list(APPEND gen_cflags "-I${gen_include}")
+ endforeach()
+-if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
+- list(APPEND gen_cflags "-isysroot")
+- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
+-endif()
+ string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
+ separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
+ separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
+--- a/third-party/CMakeLists.txt
++++ b/third-party/CMakeLists.txt
+@@ -117,13 +117,6 @@ if(CMAKE_CXX_COMPILER)
+ set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
+ endif()
+
+-if(CMAKE_OSX_SYSROOT)
+- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
+- if(DEPS_CXX_COMPILER)
+- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
+- endif()
+-endif()
+-
+ if(CMAKE_OSX_ARCHITECTURES)
+ string(REPLACE ";" "|" CMAKE_OSX_ARCHITECTURES_ALT_SEP "${CMAKE_OSX_ARCHITECTURES}")
+ # The LuaJIT build does not like being passed multiple `-arch` flags
diff --git a/app-editors/neovim/neovim-0.7.2.ebuild b/app-editors/neovim/neovim-0.7.2.ebuild
index a340a82ba6a5..0c951d155648 100644
--- a/app-editors/neovim/neovim-0.7.2.ebuild
+++ b/app-editors/neovim/neovim-0.7.2.ebuild
@@ -69,6 +69,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
"${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-0.7.2-cmake-darwin.patch"
)
src_prepare() {
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 5f18e490acbb..dc40449cb307 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -78,7 +78,7 @@ if [[ ${PV} == 9999 ]]; then
else
PATCHES+=(
"${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-darwin.patch"
+ "${FILESDIR}/${PN}-0.7.2-cmake-darwin.patch"
)
fi