summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-09 00:12:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-09 00:15:48 +0200
commitc81ce6abae16c56ce8841ce49e7cbb235416f96d (patch)
tree8bd38ed9f49eec7dd559e3d0d21b0ad4d08aed10 /app-editors/okteta
parentdev-util/ruff: add 0.0.283, drop 0.0.282 (diff)
downloadgentoo-c81ce6abae16c56ce8841ce49e7cbb235416f96d.tar.gz
gentoo-c81ce6abae16c56ce8841ce49e7cbb235416f96d.tar.bz2
gentoo-c81ce6abae16c56ce8841ce49e7cbb235416f96d.zip
app-editors/okteta: add 0.26.13
See also: https://mail.kde.org/pipermail/kde-announce-apps/2023-August/005764.html Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/okteta')
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/okteta-0.26.13.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index 5b53fca8dc1f..fb3fafcd4d31 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1 +1,2 @@
DIST okteta-0.26.12.tar.xz 1077320 BLAKE2B 9817789d099431d49f9c6f1a1d48d285f7e8a684c3a24684a8fd101d6e401ba484ecf439cda63204533a80b3437715b8de73145fa35df89cf996e2ba57d66a80 SHA512 50159269099e08bf95e4d358f9f8fbf3fb87e1f01888d5f78a1bdea83a2b56145e95c42a67eb3c82a7525b1352eb3ea1bf93187e8df0f06f35f6834a54ffa892
+DIST okteta-0.26.13.tar.xz 1080884 BLAKE2B 1e5382b6832d7b77d3739bd4dc90b3317a33c7df1e55627a3bb718ee9fb7fcf58145f0decff0cc037a88c44fdab86cf57fd8174216cbfc29d4e607557226aa57 SHA512 1f7d099acda1d39382b9d36fc75e301588a4f026e46a363f0ac15f3025a37c2edd2fac20c8097761469f4259adc20874d90acae5fa7b378f2d88e88521952fd8
diff --git a/app-editors/okteta/okteta-0.26.13.ebuild b/app-editors/okteta/okteta-0.26.13.ebuild
new file mode 100644
index 000000000000..4d7c709b3373
--- /dev/null
+++ b/app-editors/okteta/okteta-0.26.13.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.92.0
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://apps.kde.org/okteta/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 handbook? ( FDL-1.2 )"
+SLOT="5"
+IUSE="crypt"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtscript-${QTMIN}:5[scripttools]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ crypt? ( >=app-crypt/qca-2.3.0:2[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake_use_find_package crypt Qca-qt5)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ ecm_src_test
+}