summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-27 22:47:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-27 22:55:29 +0200
commit6228099a74fb31ded95477a2a20aec69d381b050 (patch)
treecb0bccca153700ef0027f803e7e1b6a92132e19b /app-editors/okteta
parentnet-libx/xdp-tools: add proxy maintainer (diff)
downloadgentoo-6228099a74fb31ded95477a2a20aec69d381b050.tar.gz
gentoo-6228099a74fb31ded95477a2a20aec69d381b050.tar.bz2
gentoo-6228099a74fb31ded95477a2a20aec69d381b050.zip
app-editors/okteta: Fix build w/ USE=-handbook
See also: https://github.com/gentoo/gentoo/pull/32474 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/okteta')
-rw-r--r--app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch35
-rw-r--r--app-editors/okteta/okteta-0.26.13.ebuild2
2 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch b/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch
new file mode 100644
index 000000000000..65beb70faae9
--- /dev/null
+++ b/app-editors/okteta/files/okteta-0.26.13-doctools-optional.patch
@@ -0,0 +1,35 @@
+From 5ca1bc18272c0ddbb3496fa29076ac2d65c034cf Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 27 Aug 2023 21:55:17 +0200
+Subject: [PATCH] Search for KF5DocTools individually
+
+Makes our ECM_HANDBOOK=forceoptional facility work while upstream is against it.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 17203b22f..3c914f178 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -93,7 +93,6 @@ if( BUILD_DESKTOPPROGRAM )
+ list(APPEND ADDITIONAL_REQUIRED_KF_COMPONENTS
+ Crash
+ DBusAddons
+- DocTools
+ )
+ endif()
+ find_package(KF5 ${REQUIRED_KF_VERSION} REQUIRED
+@@ -117,6 +116,7 @@ ecm_set_disabled_deprecation_versions(
+ # helper libs
+ add_subdirectory( libs )
+ if( BUILD_DESKTOPPROGRAM )
++ find_package(KF5DocTools ${REQUIRED_KF_VERSION} REQUIRED)
+ add_subdirectory( doc )
+ endif()
+
+--
+2.42.0
+
diff --git a/app-editors/okteta/okteta-0.26.13.ebuild b/app-editors/okteta/okteta-0.26.13.ebuild
index 4d7c709b3373..6a2d27d2f802 100644
--- a/app-editors/okteta/okteta-0.26.13.ebuild
+++ b/app-editors/okteta/okteta-0.26.13.ebuild
@@ -53,6 +53,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-doctools-optional.patch" ) # downstream
+
src_configure() {
local mycmakeargs=(
-DOMIT_EXAMPLES=ON