summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-30 13:36:46 +0100
committerSam James <sam@gentoo.org>2022-10-31 17:43:19 +0000
commitc61735c200d5a256705d2c3e8243eeb122dc390d (patch)
tree1af5107629c493d7940890502741a98109f81690 /app-editors/levee
parentapp-misc/gtk-sunlight: revbump, fix clang16 build, EAPI bump (diff)
downloadgentoo-c61735c200d5a256705d2c3e8243eeb122dc390d.tar.gz
gentoo-c61735c200d5a256705d2c3e8243eeb122dc390d.tar.bz2
gentoo-c61735c200d5a256705d2c3e8243eeb122dc390d.zip
app-editors/levee: version bump to 4.0, fix clang16 build
- wrote patch to remove all old implicit function declarations, implicit ins, etc (also sent it upstream) - patch build system to look for libtinfo (bug was also present in 3.5a, but wasn't filed in b.g.o) - call ./configure.sh with --size=256000 because configure script is using it an a non-standard way (sam: fix -Wimplicit-int, prestripping) Closes: https://bugs.gentoo.org/875740 Closes: https://bugs.gentoo.org/870889 Closes: https://bugs.gentoo.org/729264 Closes: https://bugs.gentoo.org/690168 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/28040 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/levee')
-rw-r--r--app-editors/levee/Manifest2
-rw-r--r--app-editors/levee/levee-4.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-editors/levee/Manifest b/app-editors/levee/Manifest
index 4374662abc16..3ffbb2496a5e 100644
--- a/app-editors/levee/Manifest
+++ b/app-editors/levee/Manifest
@@ -1 +1,3 @@
DIST levee-3.5a.tar.gz 67733 BLAKE2B 291b502a8c9581c2c0f2ca6714c17c86692067d5de66e987f8a7b506965a21ff149c6fe445532e9b065e40dd7e519d1ebc6b5ff69c5b4a4129138df224f71dfd SHA512 e95b4fc6370903dda07aff0a612c7f34425ab0b854d05a08f42b7e339d1a86a436316d31f3667748943e2ce2e68be7f2369e4a3b36c0715b00d31b8ab50cdaf1
+DIST levee-4.0-patches.tar.xz 12412 BLAKE2B 0cf00a16843f6a5c9e70389be357a586644b58de633177ce325e0bc475a0448ea3a38b0c7adbd3fbbbcc93e9d7f10f46b8a29d5fe00489ca3825ae0c07a3026e SHA512 f9b7ceb59e0b80e39bb1ba7a1fdd9cdf0afe450807c4a8204135fefc400756dc20f1c9c13dd03ffcb67220db8a2400eeac4ab96c755feb478461bade1fe51320
+DIST levee-4.0.tar.bz2 80596 BLAKE2B c38325a04cadb78e2961d26dff605943ccc8214232ce9bf3fb61bf7ee8f91b1e6a43631326e21e38be73d8917a290d92790cc9bc2a4ca7b186b740674fbc5f8f SHA512 7551963018674431167ee2635dccfed1648268c33ec3ae1f11c0ced89dcba280ae1f6d3ab678ad4ba8331e0928b47f6c5953758da7516bae10df9e3edd65c22c
diff --git a/app-editors/levee/levee-4.0.ebuild b/app-editors/levee/levee-4.0.ebuild
new file mode 100644
index 000000000000..5212165086a6
--- /dev/null
+++ b/app-editors/levee/levee-4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Really tiny vi clone, for things like rescue disks"
+HOMEPAGE="https://www.pell.portland.or.us/~orc/Code/levee/"
+SRC_URI="https://www.pell.portland.or.us/~orc/Code/levee/${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-patches.tar.xz"
+
+LICENSE="levee"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ !app-text/lv
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-patches
+)
+
+src_configure() {
+ export AC_CPP_PROG="$(tc-getCPP)"
+ export AC_PATH="${PATH}"
+ export AC_LIBDIR="$($(tc-getPKG_CONFIG) --libs ncurses)"
+
+ # --sive=256000 because configure.sh expects size to be a number and not the
+ # tool lize "llvm-size" or "x86_64-pc-linux-gnu-size".
+ # See #729264
+ ./configure.sh \
+ --prefix="${PREFIX}"/usr --size=256000 || die "configure failed"
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake PREFIX="${D}/${EPREFIX}" install
+}