summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-06-14 23:18:27 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-06-14 23:18:59 -0500
commitaf672b80bbf952b557244f39f8f77c3fa9c3c7f3 (patch)
tree5008e737778ba6d4ac8e0b2f14e9e871aead4c5c /app-doc/doxygen
parentdev-python/gcs-oauth2-boto-plugin: version bump to 1.13 (diff)
downloadgentoo-af672b80bbf952b557244f39f8f77c3fa9c3c7f3.tar.gz
gentoo-af672b80bbf952b557244f39f8f77c3fa9c3c7f3.tar.bz2
gentoo-af672b80bbf952b557244f39f8f77c3fa9c3c7f3.zip
app-doc/doxygen: remove LINGUAS use expand, bug #584782
doxygen has language support in form of quite a number of "translator" units. We had the habit of fine-tuning the translator units that are actually built via the LINGUAS use expand mechanism. But this is a broken approach due to the following reasons: - "translator" units are lightweight header files that are built into doxygen during compilation. No external dependencies are required. - Traditionally, the LINGUAS variable is used for packages to determine runtime language support (especially for GUI programs, etc) that usually requires additional packages to be installed - i.e., LINGUAS controls the languages supported in CLI and GUI applications. doxygen's support for translator units does *not* fit into this scheme at all. - Not all translator units have a LINGUAS equivalent (!!) - Hand selecting supported LINGUAS is a maintenance burden. Therefore, I just got rid of it and install *all supported* "translator" unconditionally. Package-Manager: portage-2.2.28
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/doxygen-1.8.11-r2.ebuild (renamed from app-doc/doxygen/doxygen-1.8.11-r1.ebuild)36
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild36
2 files changed, 0 insertions, 72 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.11-r1.ebuild b/app-doc/doxygen/doxygen-1.8.11-r2.ebuild
index d7d281deeb07..6f49a8b2c2ab 100644
--- a/app-doc/doxygen/doxygen-1.8.11-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.11-r2.ebuild
@@ -24,13 +24,6 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
-#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
-LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
-nl nb pl pt ro ru sl sk sr sv tr uk vi af)
-for X in "${LANGS[@]}" ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
@@ -61,34 +54,6 @@ DEPEND="sys-apps/sed
RESTRICT="test"
EPATCH_SUFFIX="patch"
-get_langs() {
- # using only user set linguas also fixes #263641
- my_linguas=()
- for lingua in ${LINGUAS}; do
- if has ${lingua} "${LANGS[@]}"; then
- case ${lingua} in
- hy) lingua=am ;;
- pt_BR) lingua=br ;;
- zh*) lingua=cn ;;
- cs) lingua=cz ;;
- da) lingua=dk ;;
- el*) lingua=gr ;;
- ja*) lingua=jp ;;
- ko) lingua=kr ;;
- nb) lingua=no ;;
- sl) lingua=si ;;
- tr*) lingua=tr ;;
- uk) lingua=ua ;;
- af) lingua=za ;;
- esac
- has ${lingua} "${my_linguas[@]}" ||
- my_linguas+=(${lingua})
- fi
- done
- f_langs="${my_linguas[@]^^}"
- echo ${f_langs// /;}
-}
-
pkg_setup() {
use doc && python-any-r1_pkg_setup
}
@@ -126,7 +91,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR="share/doc/${P}"
- -DLANG_CODES="$(get_langs)"
$(cmake-utils_use clang use_libclang)
$(cmake-utils_use doc build_doc)
$(cmake-utils_use doxysearch build_search)
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index fbd083eb686b..ec664ad6131d 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -25,13 +25,6 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
-#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
-LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
-nl nb pl pt ro ru sl sk sr sv tr uk vi af)
-for X in "${LANGS[@]}" ; do
- IUSE="${IUSE} linguas_${X}"
-done
-
RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
media-libs/libpng:0=
@@ -62,34 +55,6 @@ DEPEND="sys-apps/sed
RESTRICT="test"
EPATCH_SUFFIX="patch"
-get_langs() {
- # using only user set linguas also fixes #263641
- my_linguas=()
- for lingua in ${LINGUAS}; do
- if has ${lingua} "${LANGS[@]}"; then
- case ${lingua} in
- hy) lingua=am ;;
- pt_BR) lingua=br ;;
- zh*) lingua=cn ;;
- cs) lingua=cz ;;
- da) lingua=dk ;;
- el*) lingua=gr ;;
- ja*) lingua=jp ;;
- ko) lingua=kr ;;
- nb) lingua=no ;;
- sl) lingua=si ;;
- tr*) lingua=tr ;;
- uk) lingua=ua ;;
- af) lingua=za ;;
- esac
- has ${lingua} "${my_linguas[@]}" ||
- my_linguas+=(${lingua})
- fi
- done
- f_langs="${my_linguas[@]^^}"
- echo ${f_langs// /;}
-}
-
pkg_setup() {
use doc && python-any-r1_pkg_setup
}
@@ -125,7 +90,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR="share/doc/${P}"
- -DLANG_CODES="$(get_langs)"
$(cmake-utils_use clang use_libclang)
$(cmake-utils_use doc build_doc)
$(cmake-utils_use doxysearch build_search)