summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-09-14 00:42:39 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-15 15:17:23 +0300
commit6ef01054101bc167103879eb0caf0db26bdfa372 (patch)
tree70084bb725407d74f54088c7dfd84eda9c41f702 /app-crypt
parentapp-portage/flaggie: Bump to 0.99.7 (diff)
downloadgentoo-6ef01054101bc167103879eb0caf0db26bdfa372.tar.gz
gentoo-6ef01054101bc167103879eb0caf0db26bdfa372.tar.bz2
gentoo-6ef01054101bc167103879eb0caf0db26bdfa372.zip
app-crypt/rotix: update EAPI 7 -> 8
Closes: https://bugs.gentoo.org/715836 Closes: https://bugs.gentoo.org/729810 Closes: https://bugs.gentoo.org/722022 Closes: https://bugs.gentoo.org/908968 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32763 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/rotix/files/rotix-0.83-cc-cflags-lflags.patch61
-rw-r--r--app-crypt/rotix/files/rotix-0.83-nl.po-charset.patch22
-rw-r--r--app-crypt/rotix/rotix-0.83-r2.ebuild38
3 files changed, 121 insertions, 0 deletions
diff --git a/app-crypt/rotix/files/rotix-0.83-cc-cflags-lflags.patch b/app-crypt/rotix/files/rotix-0.83-cc-cflags-lflags.patch
new file mode 100644
index 000000000000..2cb97fdc52ac
--- /dev/null
+++ b/app-crypt/rotix/files/rotix-0.83-cc-cflags-lflags.patch
@@ -0,0 +1,61 @@
+From 615eaabfa00cbef1b783bd3026fdfa3f45385e53 Mon Sep 17 00:00:00 2001
+From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
+Date: Thu, 14 Sep 2023 00:20:51 +0300
+Subject: [PATCH] Respect CFLAGS, STRIP and CC, append LDFLAGS to linking
+
+--- a/Makefile
++++ b/Makefile
+@@ -22,12 +22,6 @@
+
+ include Makefile.settings
+
+-ifdef DEBUG
+-CFLAGS += -g3
+-else
+-CFLAGS += -O3
+-endif
+-
+ ifdef I18N
+ CFLAGS += -DPACKAGE=\"${PACKAGE}\" -D LOCALEDIR=\"${LOCALE}\"
+ endif
+@@ -39,7 +33,7 @@ endif
+ all : rotix po
+
+ rotix : rot.o help.o rotix.o
+- $(CC) -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o
++ $(CC) -Wall $(CFLAGS) $(LDFLAGS) $(LFLAGS) -o rotix rot.o help.o rotix.o
+ ifdef STRIP
+ ifndef DEBUG
+ $(STRIP) rotix
+--- a/configure
++++ b/configure
+@@ -82,14 +82,7 @@ if [ "$i18n" = "1" ]; then
+ fi;
+ fi
+
+-if type gcc > /dev/null 2> /dev/null; then
+- echo "CC=gcc" >> Makefile.settings;
+-elif type cc > /dev/null 2> /dev/null; then
+- echo "CC=cc" >> Makefile.settings;
+-else
+- echo 'Cannot find a C compiler, aborting.'
+- exit 1;
+-fi
++echo "CC?=cc" >> Makefile.settings;
+
+ if [ "$strip" = "1" ]; then
+ if type strip > /dev/null 2> /dev/null; then
+@@ -101,10 +94,7 @@ if [ "$strip" = "1" ]; then
+ else
+ echo 'No strip utility found, cannot remove unnecessary parts from executable.'
+ echo ''
+- echo 'STRIP=0' >> Makefile.settings;
+ fi
+-else
+- echo 'STRIP=0' >> Makefile.settings;
+ fi
+
+ case "$arch" in
+--
+2.41.0
+
diff --git a/app-crypt/rotix/files/rotix-0.83-nl.po-charset.patch b/app-crypt/rotix/files/rotix-0.83-nl.po-charset.patch
new file mode 100644
index 000000000000..9cbc892da0c0
--- /dev/null
+++ b/app-crypt/rotix/files/rotix-0.83-nl.po-charset.patch
@@ -0,0 +1,22 @@
+https://github.com/shemminga/rotix/pull/2
+From: =?UTF-8?q?Ra=C3=BAl=20Benencia?= <rul@kalgan.cc>
+Date: Mon, 18 Oct 2021 20:28:50 -0700
+Subject: [PATCH] Fix NL translation
+
+Avoids the following error:
+ po/NL.po: warning: Charset "CHARSET" is not a portable encoding name.
+ Message conversion to user's charset might not work.
+
+--- a/po/NL.po
++++ b/po/NL.po
+@@ -15,8 +15,8 @@ msgstr ""
+ "Last-Translator: Sjoerd Hemminga <sjoerd@huiswerkservice.nl>\n"
+ "Language-Team: NL <NL@li.org>\n"
+ "MIME-Version: 1.0\n"
+-"Content-Type: text/plain; charset=CHARSET\n"
+-"Content-Transfer-Encoding: ENCODING\n"
++"Content-Type: text/plain; charset=ASCII\n"
++"Content-Transfer-Encoding: 8bit\n"
+
+ #: rotix.c:134 rotix.c:145 rotix.c:185
+ msgid "rotix: you cannot specify both an inputfile and a text\n"
diff --git a/app-crypt/rotix/rotix-0.83-r2.ebuild b/app-crypt/rotix/rotix-0.83-r2.ebuild
new file mode 100644
index 000000000000..ee8600113fa1
--- /dev/null
+++ b/app-crypt/rotix/rotix-0.83-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Rotix allows you to generate rotational obfuscations"
+HOMEPAGE="https://github.com/shemminga/rotix"
+SRC_URI="https://github.com/shemminga/${PN}/releases/download/${PV}/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="nls"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+PATCHES=(
+ "${FILESDIR}/rotix-0.83-cc-cflags-lflags.patch"
+ "${FILESDIR}/rotix-0.83-locale.patch"
+ "${FILESDIR}/rotix-0.83-interix.patch"
+ "${FILESDIR}/rotix-0.83-nl.po-charset.patch"
+)
+
+src_configure() {
+ econf --i18n=$(usex nls 1 0) --strip=0 --debug=0
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc README
+}