summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/cryptkeeper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/cryptkeeper')
-rw-r--r--app-crypt/cryptkeeper/Manifest1
-rw-r--r--app-crypt/cryptkeeper/cryptkeeper-0.9.5.ebuild44
-rw-r--r--app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-binutils-gold.patch15
-rw-r--r--app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-fix-ftbfs-gcc-4.7-672010.patch18
-rw-r--r--app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-fix_cryptkeeper.desktop.patch17
-rw-r--r--app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-is_mounted_overflow_fix.patch53
-rw-r--r--app-crypt/cryptkeeper/metadata.xml15
7 files changed, 163 insertions, 0 deletions
diff --git a/app-crypt/cryptkeeper/Manifest b/app-crypt/cryptkeeper/Manifest
new file mode 100644
index 000000000000..51017343cf63
--- /dev/null
+++ b/app-crypt/cryptkeeper/Manifest
@@ -0,0 +1 @@
+DIST cryptkeeper-0.9.5.tar.gz 222671 SHA256 1f9805d31562e448bf9bc11fdc2879f908ba42bfef5ad6adfa3877fc3b306984 SHA512 824c8b941d46904dd7f4b12a5f217aba25c848e016473d44ec71739baec78a7782dd00bb5d0c5dafc947235eddf558b8fe01a92e23b88b23352a05d0389cea3d WHIRLPOOL 7cf04ef6626cfc49d773ba67b83ab54f5d47d16a88d1541a9d1d8d3d2add9c744403759904ed2fce1feda0f9a654eeec39e8fd0c169418823b60300917b63ab4
diff --git a/app-crypt/cryptkeeper/cryptkeeper-0.9.5.ebuild b/app-crypt/cryptkeeper/cryptkeeper-0.9.5.ebuild
new file mode 100644
index 000000000000..53e0fff666b0
--- /dev/null
+++ b/app-crypt/cryptkeeper/cryptkeeper-0.9.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit base eutils gnome2
+
+DESCRIPTION="EncFS system tray applet for GNOME"
+HOMEPAGE="http://tom.noflag.org.uk/cryptkeeper.html"
+SRC_URI="http://tom.noflag.org.uk/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="gnome-base/gconf:2
+ >=sys-fs/encfs-1.7.2
+ >=sys-fs/fuse-2.8.0
+ gnome-extra/zenity"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-binutils-gold.patch"
+ "${FILESDIR}/${P}-fix_cryptkeeper.desktop.patch"
+ "${FILESDIR}/${P}-fix-ftbfs-gcc-4.7-672010.patch"
+ "${FILESDIR}/${P}-is_mounted_overflow_fix.patch"
+)
+
+DOCS="TODO"
+
+src_prepare() {
+ base_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
diff --git a/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-binutils-gold.patch b/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-binutils-gold.patch
new file mode 100644
index 000000000000..875222592505
--- /dev/null
+++ b/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-binutils-gold.patch
@@ -0,0 +1,15 @@
+Description: Fixes a build failure using binutils-gold
+Author: Franceco Namuri <francesco@namuri.it>
+Index: cryptkeeper-0.9.5/configure
+===================================================================
+--- cryptkeeper-0.9.5.orig/configure 2009-10-18 13:58:01.000000000 +0200
++++ cryptkeeper-0.9.5/configure 2011-12-11 12:04:13.045285159 +0100
+@@ -6707,7 +6707,7 @@
+
+ CFLAGS="$CFLAGS $DEP_CFLAGS $GNOME_KEYRING_CFLAGS"
+ CXXFLAGS="$CFLAGS"
+-LIBS="$DEP_LIBS $GNOME_KEYRING_LIBS"
++LIBS="-lX11 $DEP_LIBS $GNOME_KEYRING_LIBS"
+
+ #AC_PROG_LIBTOOL
+
diff --git a/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-fix-ftbfs-gcc-4.7-672010.patch b/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-fix-ftbfs-gcc-4.7-672010.patch
new file mode 100644
index 000000000000..e9f9f018bc25
--- /dev/null
+++ b/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-fix-ftbfs-gcc-4.7-672010.patch
@@ -0,0 +1,18 @@
+Description: add missing include to avoid FTBFS with gcc 4.7
+Origin: vendor
+Bug-Debian: http://bugs.debian.org/672010
+Forwarded: no
+Author: Paul Tagliamonte <tag@pault.ag>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2012-05-15
+
+--- a/src/lsof.cpp 2012-05-09 21:27:01.138367215 -0400
++++ b/src/lsof.cpp 2012-05-09 21:26:52.398367682 -0400
+@@ -21,6 +21,7 @@
+ #include <vector>
+ #include <assert.h>
+ #include <cstring>
++#include <unistd.h>
+ #include "lsof.h"
+
+ fsuser::fsuser(const char *pid, const char *name)
diff --git a/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-fix_cryptkeeper.desktop.patch b/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-fix_cryptkeeper.desktop.patch
new file mode 100644
index 000000000000..464f3ca77953
--- /dev/null
+++ b/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-fix_cryptkeeper.desktop.patch
@@ -0,0 +1,17 @@
+Description: Fixes the category of cryptkeeper menu item
+Author: Francesco Namuri <francesco@namuri.it>
+Index: cryptkeeper-0.9.5/cryptkeeper.desktop
+===================================================================
+--- cryptkeeper-0.9.5.orig/cryptkeeper.desktop 2011-12-11 12:04:59.053286893 +0100
++++ cryptkeeper-0.9.5/cryptkeeper.desktop 2011-12-11 12:05:02.777287034 +0100
+@@ -1,9 +1,8 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Cryptkeeper
+ Exec=cryptkeeper
+ Icon=cryptkeeper
+-Categories=Application;System;
++Categories=System;GTK;Security;
+ Terminal=false
+ Type=Application
+ StartupNotify=false
diff --git a/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-is_mounted_overflow_fix.patch b/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-is_mounted_overflow_fix.patch
new file mode 100644
index 000000000000..c2a9a0ca0085
--- /dev/null
+++ b/app-crypt/cryptkeeper/files/cryptkeeper-0.9.5-is_mounted_overflow_fix.patch
@@ -0,0 +1,53 @@
+commit 86b960a528df7118ab43b629bbd906db7459300d
+Author: Jon Dowland <jmtd@debian.org>
+Date: Sun May 22 12:48:39 2011 +0100
+
+ fix is_mounted (memory leaks and NULL access)
+
+ Ensure that the return of realpath is checked for NULL before
+ access. Ensure that the return value is free'd before it falls
+ out of scope. Related tidying up.
+
+diff --git a/src/encfs_wrapper.cpp b/src/encfs_wrapper.cpp
+index 347337b..961818b 100644
+--- a/src/encfs_wrapper.cpp
++++ b/src/encfs_wrapper.cpp
+@@ -33,24 +33,24 @@
+
+ bool is_mounted(const char *mount_dir)
+ {
++ struct mntent *m;
+ FILE *f = setmntent("/etc/mtab", "r");
+- char *mount_dir_expanded = realpath(mount_dir, NULL);
+- if (mount_dir_expanded == NULL) {
+- // no such file or dir, ...
+- // so: not mounted
+- // perror("cryptkeeper, is_mounted");
++ char *mount_dir_expanded, *mnt_dir_expanded;
++
++ if (!(mount_dir_expanded = realpath(mount_dir, NULL)))
+ return false;
+- }
+- for (;;) {
+- char *mnt_dir_expanded;
+- struct mntent *m = getmntent(f);
+- if (!m) break;
+- mnt_dir_expanded = realpath(m->mnt_dir, NULL);
+- if (strcmp(mount_dir_expanded, mnt_dir_expanded)==0) {
++
++ while(m = getmntent(f)) {
++ if(mnt_dir_expanded = realpath(m->mnt_dir, NULL)) {
++ if (strcmp(mount_dir_expanded, mnt_dir_expanded)==0) {
++ free(mnt_dir_expanded);
++ free(mount_dir_expanded);
++ return true;
++ }
+ free(mnt_dir_expanded);
+- return true;
+- }
++ }
+ }
++ free(mount_dir_expanded);
+ return false;
+ }
+
diff --git a/app-crypt/cryptkeeper/metadata.xml b/app-crypt/cryptkeeper/metadata.xml
new file mode 100644
index 000000000000..ad4f9bee6d8f
--- /dev/null
+++ b/app-crypt/cryptkeeper/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>phobosk@kbfx.net</email>
+ <name>PhobosK</name>
+ <description>Proxy maintainer. Assign bugs to him.</description>
+</maintainer>
+<longdescription>
+Cryptkeeper is a Linux system tray applet that manages EncFS encrypted folders.
+It allows users to mount and unmount encfs folders, to change the password and
+to create new crypted folders. It integrates with a preferred file manager.
+</longdescription>
+</pkgmetadata>