summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-15 21:31:13 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-15 21:31:13 +0200
commitdc88f1361fb55b30082cc7893582c6af8804f559 (patch)
tree98e08a1b2b1456723e74d7714d9293f950695129 /app-crypt/acme/acme-0.13.0.ebuild
parentapp-emulation/kompose: Remove old (diff)
downloadgentoo-dc88f1361fb55b30082cc7893582c6af8804f559.tar.gz
gentoo-dc88f1361fb55b30082cc7893582c6af8804f559.tar.bz2
gentoo-dc88f1361fb55b30082cc7893582c6af8804f559.zip
app-crypt/acme: Version bump to 0.13.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-crypt/acme/acme-0.13.0.ebuild')
-rw-r--r--app-crypt/acme/acme-0.13.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/acme/acme-0.13.0.ebuild b/app-crypt/acme/acme-0.13.0.ebuild
new file mode 100644
index 000000000000..ce2e17f3d795
--- /dev/null
+++ b/app-crypt/acme/acme-0.13.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e "/'argparse',/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -w ${PN} || die
+}