summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-03-06 15:57:47 +0000
committerMarek Szuba <marecki@gentoo.org>2023-03-06 15:57:47 +0000
commitde04df79b6353f31bd0940f4d20f723d7a78ce76 (patch)
tree4a9e6c141b784595dd48d32eb960225db45074e9 /app-backup
parentdev-vcs/git-machete: add 3.16.0 (diff)
downloadgentoo-de04df79b6353f31bd0940f4d20f723d7a78ce76.tar.gz
gentoo-de04df79b6353f31bd0940f4d20f723d7a78ce76.tar.bz2
gentoo-de04df79b6353f31bd0940f4d20f723d7a78ce76.zip
app-backup/borgmatic: add 1.7.8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.7.8.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index e6fe205d055d..c0aa07708f27 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,3 +1,4 @@
DIST borgmatic-1.7.2.tar.gz 333772 BLAKE2B fd628e9c77547686d4edf5d1066d3c171575f4d923ebc5205c5eb64f3a960e94c121282e9f4fb02b1291a81011a18dc393c6d13a07f215585459e7a5b55f8107 SHA512 6ec12ec25ae4d0210bb9114795c1ea292d8236f9e68c9425e24ee7b580796504e4c317a3fcf778806a33bbd3db68669beb4ef7a88ec538c1bd432db9a2845b3e
DIST borgmatic-1.7.5.tar.gz 338412 BLAKE2B e27fd709070a27c2ddd01fdfe23ef9caeb942c52d756332b4abd6d6cf39724656677a0d142a5392e35e0a0f25958421fe23edf04a252d212d761f48a0c320d9b SHA512 c27a364617e0e8fc1c11adac5375deac4e1663236a545d3fb70280974614d50ffe3821010ed5e4345afa3c3dab5f45c0d3bbfc946f50321601acb56965fd555d
DIST borgmatic-1.7.7.tar.gz 348839 BLAKE2B 686a5552bdace0e44ced612448fd9a9609d9df2dfb41007f0432bbb6fe9d4c2ef154a215eef63f4aed4626471feda52142d3511498901545a3ab4bbf3171c14f SHA512 e1a7c20a17a4ad37ce348feb89e1a3b34912ae6730742e6b4c822b7a1026e3630167645154268f47922a106621cd02d5f06ada448ac844dfd7c9ff46660ca2ec
+DIST borgmatic-1.7.8.tar.gz 350233 BLAKE2B 3fcd392983f73ec5e97f0dc6b96e211d7f1e1d1a4ce95c635c675cf043e796925df53c30c1e4f8eb1a095d9ec5ff81e90edee5ff2576f4683053d3108004afd9 SHA512 bcc65fdb7ea1171fb61deda9b1f69a00596e1e10a99508d336977b694bd8f93d74837aad9211bf1065b785220aaf1460a3ea403bf23fa4873d1bf4c6b4016525
diff --git a/app-backup/borgmatic/borgmatic-1.7.8.ebuild b/app-backup/borgmatic/borgmatic-1.7.8.ebuild
new file mode 100644
index 000000000000..87cdd1fed96c
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.7.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.3-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}