summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-19 03:11:39 +0000
committerSam James <sam@gentoo.org>2021-01-19 03:11:39 +0000
commitd287bc5ea064464f863ca2a0df99cbd8c38c3564 (patch)
tree2a4cd5fc14954403bd6562601057d434bae3e334 /app-arch
parentapp-arch/wimlib: EAPI 7 (diff)
downloadgentoo-d287bc5ea064464f863ca2a0df99cbd8c38c3564.tar.gz
gentoo-d287bc5ea064464f863ca2a0df99cbd8c38c3564.tar.bz2
gentoo-d287bc5ea064464f863ca2a0df99cbd8c38c3564.zip
app-arch/wimlib: cleanup old
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/wimlib/Manifest1
-rw-r--r--app-arch/wimlib/wimlib-1.12.0.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/app-arch/wimlib/Manifest b/app-arch/wimlib/Manifest
index 01df841c87a7..a14a38085f3d 100644
--- a/app-arch/wimlib/Manifest
+++ b/app-arch/wimlib/Manifest
@@ -1,2 +1 @@
-DIST wimlib-1.12.0.tar.gz 1014508 BLAKE2B d12f4e0b458fe756b74c67f2f643256c44021e0f0c3e2a3a70eb87647c3c6cabd93413917bf8a8c6ab6820860c407f4454454719227f5cbf1a9a81a7bedc1a6e SHA512 0343b37550366f07fd6a6689f4445f390187beddde677f4d6d831c07936d03b613ae95f612ec7a75e978a5e678f33ab766d0f3b3d942886df56e4ef77d4b07b9
DIST wimlib-1.13.0.tar.gz 1035146 BLAKE2B 305d4bd4a0299c99b537c2bc59c674740239d3fe7c240038f4846849f36046ef587b04643d5a482c876668bf8f9a94a7b45a5e4f12c6d235a579a08c3879acff SHA512 a7ec729dda07b3884a851533a3c9e9db3061d9f6273ec318e40ece3687f4671f66989c07c080fa9cdcf5f01318c5eba7256b58f15f711b3ff14f4eb61c2114cb
diff --git a/app-arch/wimlib/wimlib-1.12.0.ebuild b/app-arch/wimlib/wimlib-1.12.0.ebuild
deleted file mode 100644
index 58cbc3ce1b7a..000000000000
--- a/app-arch/wimlib/wimlib-1.12.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools pax-utils
-
-if [[ -z ${PV%%*9999} ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://wimlib.net/${PN}"
-else
- MY_PV="${PV/_/-}"
- MY_PV="${MY_PV^^}"
- SRC_URI="https://wimlib.net/downloads/${PN}-${MY_PV}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="The open source Windows Imaging (WIM) library"
-HOMEPAGE="https://wimlib.net/"
-
-LICENSE="|| ( GPL-3+ LGPL-3+ ) CC0-1.0"
-SLOT="0"
-IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl test threads yasm"
-REQUIRED_USE="cpu_flags_x86_ssse3? ( !openssl )"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
- cpu_flags_x86_ssse3? (
- yasm? ( dev-lang/yasm )
- !yasm? ( dev-lang/nasm )
- )
-"
-RDEPEND="
- dev-libs/libxml2:2
- ntfs? ( sys-fs/ntfs3g )
- fuse? ( sys-fs/fuse:0 )
- openssl? ( dev-libs/openssl:0= )
- iso? (
- app-arch/cabextract
- app-cdr/cdrtools
- )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/syslinux-path.patch" )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with ntfs ntfs-3g)
- $(use_with fuse)
- $(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
- $(use_with openssl libcrypto)
- $(use_enable threads multithreaded-compression)
- $(use_enable test enable-test-support)
- --disable-static
- )
- ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake
- pax-mark m "${S}"/.libs/wimlib-imagex
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}