summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/tarsync
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/tarsync')
-rw-r--r--app-arch/tarsync/Manifest1
-rw-r--r--app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch59
-rw-r--r--app-arch/tarsync/files/tarsync-0.2.1-make.patch13
-rw-r--r--app-arch/tarsync/metadata.xml7
-rw-r--r--app-arch/tarsync/tarsync-0.2.1-r1.ebuild34
5 files changed, 114 insertions, 0 deletions
diff --git a/app-arch/tarsync/Manifest b/app-arch/tarsync/Manifest
new file mode 100644
index 000000000000..f079307332e1
--- /dev/null
+++ b/app-arch/tarsync/Manifest
@@ -0,0 +1 @@
+DIST tarsync-0.2.1.tar.bz2 13593 SHA256 5cbfdcb637b899c29bfb74e97a09daff6173c45201840aa5ac251eb93aef1775 SHA512 bebf8e495ad196c002414c41f9fe9737b5300de18b7c3b16576a7d3bfd94608f36f1b86cb6ed4879c600b71c7706255d9b2d4140b73c5743a473fa2500dbca2d WHIRLPOOL 27ec7ee1942b553aa05e47789b5d0c227a7ba4b239cf6837aeadf168420ebb671b0ac237dbf739d83d538b18d24f054a1e62364b7bd93811ed132958a1ab0417
diff --git a/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch b/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch
new file mode 100644
index 000000000000..f11c86bb248a
--- /dev/null
+++ b/app-arch/tarsync/files/tarsync-0.2.1-gcc5.patch
@@ -0,0 +1,59 @@
+diff --git a/excludes.c b/excludes.c
+index b7c928d..fa43cef 100644
+--- a/excludes.c
++++ b/excludes.c
+@@ -106,7 +106,7 @@ build_exclude(fnm_exclude **ex_ptr, const char *pattern)
+ }
+
+
+-inline int
++int
+ match_excludes(const char *dir, const char *file, fnm_exclude **excludes)
+ {
+ char *p;
+diff --git a/main.c b/main.c
+index 84feed4..2c2da3e 100644
+--- a/main.c
++++ b/main.c
+@@ -42,8 +42,8 @@ int remove_node(const char *path, struct stat *st);
+ int ensure_files_layout(const tar_entry **ttar, const unsigned int ttar_count, tar_entry ***missing,
+ unsigned int *missing_count, tar_entry ***existing, unsigned int *existing_count,
+ fnm_exclude **excludes);
+-inline int check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st);
+-inline int enforce_owner(const char *path, const tar_entry *t, struct stat *st);
++int check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st);
++int enforce_owner(const char *path, const tar_entry *t, struct stat *st);
+ int copy_whole_file(cfile *tar_cfh, const tar_entry *ttent);
+
+ static int check_mtime = 1;
+@@ -669,7 +669,7 @@ recursively_delete_dir(const char *path)
+ return ret;
+ }
+
+-inline int
++int
+ check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st)
+ {
+ int type;
+@@ -685,7 +685,7 @@ check_existing_node(const struct dirent *de, const tar_entry *t, struct stat *st
+ return 0;
+ }
+
+-inline int
++int
+ enforce_owner(const char *path, const tar_entry *t, struct stat *st)
+ {
+ struct stat st2;
+diff --git a/tar.c b/tar.c
+index 792ccd4..42dc8e7 100644
+--- a/tar.c
++++ b/tar.c
+@@ -40,7 +40,7 @@ int check_str_chksum(const char *block)
+
+ /* possibly this could be done different, what of endptr of strtol?
+ Frankly I worry about strtol trying to go too far and causing a segfault, due to tar fields not always having trailing \0 */
+-inline unsigned long octal_str2long(const char *string, unsigned int length)
++unsigned long octal_str2long(const char *string, unsigned int length)
+ {
+ if(string[length]) {
+ char *ptr = strndup(string, length);
diff --git a/app-arch/tarsync/files/tarsync-0.2.1-make.patch b/app-arch/tarsync/files/tarsync-0.2.1-make.patch
new file mode 100644
index 000000000000..72591115a45a
--- /dev/null
+++ b/app-arch/tarsync/files/tarsync-0.2.1-make.patch
@@ -0,0 +1,13 @@
+Respect CC and LDFLAGS.
+
+--- Makefile
++++ Makefile
+@@ -2,7 +2,7 @@
+ CC=gcc
+ endif
+ tarsync: main.o names.o tar.o string-misc.o fs.o options.o excludes.o
+- gcc $(CFLAGS) $^ -o tarsync -lcfile
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o tarsync -lcfile
+ all: tarsync
+
+ clean:
diff --git a/app-arch/tarsync/metadata.xml b/app-arch/tarsync/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/app-arch/tarsync/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-arch/tarsync/tarsync-0.2.1-r1.ebuild b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..608e53a35739
--- /dev/null
+++ b/app-arch/tarsync/tarsync-0.2.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-arch/tarsync/tarsync-0.2.1-r1.ebuild?view=markup"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86 ~amd64-linux"
+IUSE=""
+
+DEPEND=">=dev-util/diffball-0.7"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-gcc5.patch
+}
+
+src_install() {
+ dobin "${PN}" #make install doesn't support prefix
+}