summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-01 15:11:39 +0100
committerSam James <sam@gentoo.org>2023-09-01 15:12:01 +0100
commit15aff651a034787d585be6bd25e26192dcffc190 (patch)
treefcc6aec6c92ab40814f52182aeaaa6231c7800ba /app-admin
parentsys-apps/coreutils: fix build w/ <openssl-3 (diff)
downloadgentoo-15aff651a034787d585be6bd25e26192dcffc190.tar.gz
gentoo-15aff651a034787d585be6bd25e26192dcffc190.tar.bz2
gentoo-15aff651a034787d585be6bd25e26192dcffc190.zip
app-admin/mongo-tools: fix dev-lang/go dep
It should be a BDEPEND, not a DEPEND, and a subslot operator isn't really appropriate here (and is at least unconventional). Noticed after a discussion w/ parona. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mongo-tools/mongo-tools-100.4.1-r1.ebuild (renamed from app-admin/mongo-tools/mongo-tools-100.4.1.ebuild)8
-rw-r--r--app-admin/mongo-tools/mongo-tools-100.5.1-r1.ebuild (renamed from app-admin/mongo-tools/mongo-tools-100.5.1.ebuild)8
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.2.15-r1.ebuild (renamed from app-admin/mongo-tools/mongo-tools-4.2.15.ebuild)8
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.2.17-r1.ebuild (renamed from app-admin/mongo-tools/mongo-tools-4.2.17.ebuild)8
4 files changed, 20 insertions, 12 deletions
diff --git a/app-admin/mongo-tools/mongo-tools-100.4.1.ebuild b/app-admin/mongo-tools/mongo-tools-100.4.1-r1.ebuild
index 52cc5e43f884..cd615af4e5cd 100644
--- a/app-admin/mongo-tools/mongo-tools-100.4.1.ebuild
+++ b/app-admin/mongo-tools/mongo-tools-100.4.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,10 +12,12 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 ~riscv"
IUSE="sasl ssl"
-DEPEND="dev-lang/go:=
+DEPEND="
net-libs/libpcap
sasl? ( dev-libs/cyrus-sasl )
- ssl? ( dev-libs/openssl:0= )"
+ ssl? ( dev-libs/openssl:0= )
+"
+BDEPEND="dev-lang/go"
# Do not complain about CFLAGS etc since go projects do not use them.
QA_FLAGS_IGNORED='.*'
diff --git a/app-admin/mongo-tools/mongo-tools-100.5.1.ebuild b/app-admin/mongo-tools/mongo-tools-100.5.1-r1.ebuild
index 5fdee0d14afe..cd615af4e5cd 100644
--- a/app-admin/mongo-tools/mongo-tools-100.5.1.ebuild
+++ b/app-admin/mongo-tools/mongo-tools-100.5.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,10 +12,12 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 ~riscv"
IUSE="sasl ssl"
-DEPEND="dev-lang/go:=
+DEPEND="
net-libs/libpcap
sasl? ( dev-libs/cyrus-sasl )
- ssl? ( dev-libs/openssl:0= )"
+ ssl? ( dev-libs/openssl:0= )
+"
+BDEPEND="dev-lang/go"
# Do not complain about CFLAGS etc since go projects do not use them.
QA_FLAGS_IGNORED='.*'
diff --git a/app-admin/mongo-tools/mongo-tools-4.2.15.ebuild b/app-admin/mongo-tools/mongo-tools-4.2.15-r1.ebuild
index 82253adc9ab4..18d33ebdac8a 100644
--- a/app-admin/mongo-tools/mongo-tools-4.2.15.ebuild
+++ b/app-admin/mongo-tools/mongo-tools-4.2.15-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,10 +15,12 @@ SLOT="0"
KEYWORDS="amd64 ~arm64"
IUSE="sasl ssl"
-DEPEND="dev-lang/go:=
+DEPEND="
net-libs/libpcap
sasl? ( dev-libs/cyrus-sasl )
- ssl? ( dev-libs/openssl:0= )"
+ ssl? ( dev-libs/openssl:0= )
+"
+BDEPEND="dev-lang/go"
# Do not complain about CFLAGS etc since go projects do not use them.
QA_FLAGS_IGNORED='.*'
diff --git a/app-admin/mongo-tools/mongo-tools-4.2.17.ebuild b/app-admin/mongo-tools/mongo-tools-4.2.17-r1.ebuild
index 1c622b0ee6a7..b241e07817c3 100644
--- a/app-admin/mongo-tools/mongo-tools-4.2.17.ebuild
+++ b/app-admin/mongo-tools/mongo-tools-4.2.17-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,10 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE="sasl ssl"
-DEPEND="dev-lang/go:=
+DEPEND="
net-libs/libpcap
sasl? ( dev-libs/cyrus-sasl )
- ssl? ( dev-libs/openssl:0= )"
+ ssl? ( dev-libs/openssl:0= )
+"
+BDEPEND="dev-lang/go"
# Do not complain about CFLAGS etc since go projects do not use them.
QA_FLAGS_IGNORED='.*'