summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/supernova
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/supernova')
-rw-r--r--app-admin/supernova/Manifest3
-rw-r--r--app-admin/supernova/metadata.xml14
-rw-r--r--app-admin/supernova/supernova-1.0.7.ebuild39
-rw-r--r--app-admin/supernova/supernova-2.0.0.ebuild45
-rw-r--r--app-admin/supernova/supernova-2.0.5.ebuild53
5 files changed, 154 insertions, 0 deletions
diff --git a/app-admin/supernova/Manifest b/app-admin/supernova/Manifest
new file mode 100644
index 000000000000..4b9734c14dec
--- /dev/null
+++ b/app-admin/supernova/Manifest
@@ -0,0 +1,3 @@
+DIST supernova-1.0.7.tar.gz 17783 SHA256 e0336590e8b4a73404acbfd7379285c631daf628baaba64c9f42d839982d9949 SHA512 54e98ab0a7f926b96dc2da62951cb552767515ae8a94ef88fbcf654db6079c91d6971b526663116e36bab795939605ec108aa39247e57c5dacfccbab4048b7d9 WHIRLPOOL b769f5c4b3d284eb17447b9b9d63b12bbcb8c8c87637ce8e6999d3bdf245f5b47194f9454e4b273c0b176b7fae5497346a0657d34ed335b8e7039cd273cb9fe0
+DIST supernova-2.0.0.tar.gz 18298 SHA256 43b27ee9ed2ca7b0b5860bf52422750e215b60cb71eca106a57b4f900faef24e SHA512 a5c439cfe489991d5ae7f0f63e858b1200ac8df8f1556871f79f8cfc97862d46aae555aee9c97565308388305bd721ecce1f91221824f425caf19acb92f5ac8a WHIRLPOOL e4514e9c0312c68f1c017a92f1959180db042da0cd38ef83079bcee93344758383b41c06b5c51d1139b970dfdae51fda03f8f041d1788a533f9ca71645a7bcf9
+DIST supernova-2.0.5.tar.gz 18219 SHA256 8219f6e42e364aceba5d1b70211522ba76fafad16374f71319a0e43c7f615489 SHA512 737649bb0d5e7ee21d9721cba8556617afffdd8cfa287f9d08fa3d81bfa98eb35a6aeeded9c13e600d355616cd3983bfc80148c0934d2b7791da2724e420c9c0 WHIRLPOOL b9204b5fb265bd7384b8724c62a5a10a4220f34c9ebe20f8f95945f12399c6fb291abb3086b5a09cb988fca8229ec99377f84394c98f15b6874ae140396ab8a9
diff --git a/app-admin/supernova/metadata.xml b/app-admin/supernova/metadata.xml
new file mode 100644
index 000000000000..e240c5fe8b82
--- /dev/null
+++ b/app-admin/supernova/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rackerhacker/supernova</remote-id>
+ <remote-id type="pypi">supernova</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/supernova/supernova-1.0.7.ebuild b/app-admin/supernova/supernova-1.0.7.ebuild
new file mode 100644
index 000000000000..95f61b0cef80
--- /dev/null
+++ b/app-admin/supernova/supernova-1.0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+DESCRIPTION="novaclient wrapper for multiple nova environments"
+HOMEPAGE="https://github.com/rackerhacker/supernova"
+SRC_URI="https://github.com/major/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ >=dev-python/keyring-0.9.2[${PYTHON_USEDEP}]
+ dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example_configs/. )
+
+ distutils-r1_python_install_all
+
+ newbashcomp contrib/${PN}-completion.bash ${PN}
+}
diff --git a/app-admin/supernova/supernova-2.0.0.ebuild b/app-admin/supernova/supernova-2.0.0.ebuild
new file mode 100644
index 000000000000..03dc2ddffea4
--- /dev/null
+++ b/app-admin/supernova/supernova-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+DESCRIPTION="novaclient wrapper for multiple nova environments"
+HOMEPAGE="https://github.com/rackerhacker/supernova"
+SRC_URI="https://github.com/major/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/keyring-0.9.2[${PYTHON_USEDEP}]
+ dev-python/python-novaclient[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example_configs/. )
+
+ distutils-r1_python_install_all
+
+ newbashcomp contrib/${PN}-completion.bash ${PN}
+}
diff --git a/app-admin/supernova/supernova-2.0.5.ebuild b/app-admin/supernova/supernova-2.0.5.ebuild
new file mode 100644
index 000000000000..56a25edac926
--- /dev/null
+++ b/app-admin/supernova/supernova-2.0.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="novaclient wrapper for multiple nova environments"
+HOMEPAGE="https://github.com/rackerhacker/supernova"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/keyring-0.9.2[${PYTHON_USEDEP}]
+ dev-python/python-novaclient[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ if use doc; then
+ mkdocs build || die "docs failed to build"
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( site/. )
+ use examples && local EXAMPLES=( example_configs/. )
+
+ distutils-r1_python_install_all
+
+ newbashcomp contrib/${PN}-completion.bash ${PN}
+}