summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-08-07 08:22:52 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2021-08-19 18:38:13 +0200
commit82513fcb978d0c8670e755c030bd5c6b119a70de (patch)
tree47048ad463b884be8bdf282bfced844009b06f34 /app-admin/mongosh-bin
parentapp-admin/mongo-tools: bump to 100.4.1 (diff)
downloadgentoo-82513fcb978d0c8670e755c030bd5c6b119a70de.tar.gz
gentoo-82513fcb978d0c8670e755c030bd5c6b119a70de.tar.bz2
gentoo-82513fcb978d0c8670e755c030bd5c6b119a70de.zip
app-admin/mongosh-bin: the new mongodb shell
The mongo command from dev-db/mongodb is deprecated and to be removed in later releases. A binary package is used because the project is built with nodejs and thus downloads packages from the Internet. Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'app-admin/mongosh-bin')
-rw-r--r--app-admin/mongosh-bin/Manifest2
-rw-r--r--app-admin/mongosh-bin/metadata.xml19
-rw-r--r--app-admin/mongosh-bin/mongosh-bin-1.0.4.ebuild34
3 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/mongosh-bin/Manifest b/app-admin/mongosh-bin/Manifest
new file mode 100644
index 000000000000..b6d60af03761
--- /dev/null
+++ b/app-admin/mongosh-bin/Manifest
@@ -0,0 +1,2 @@
+DIST mongosh-1.0.4_arm64.tgz 58296826 BLAKE2B 87304d259e731ac63b52f63e8277746042df90eeaa67771265d45fd9450950d878a20996a34285db4f8dbac9c4877c37391b54b6b9e57ff0409e0d72bec1c5a1 SHA512 ad9e9cf733915cfd6e9e2140b90cfbbc77f63160331683dee740e906c69b5993ac9704ac0bfbe8b5227eb474a0db75cddd8df310150f737de28fef00184d1280
+DIST mongosh-1.0.4_x64.tgz 62341440 BLAKE2B af4394c1312825ca0718f1ec836cde64c212533ae2210dcb64363042d066304e558c5822e46362323aeedb5cbc402fae1999689b338102d8ba8de5c74379cf21 SHA512 07091f85b14b80fcfe334ced3a1773d206e9dd09faa3ac0ec6045503f222ccba0735a861bb4088d4c7687783de37e2134c8beeaa160cd838f197233e68aae796
diff --git a/app-admin/mongosh-bin/metadata.xml b/app-admin/mongosh-bin/metadata.xml
new file mode 100644
index 000000000000..2e57b644abfb
--- /dev/null
+++ b/app-admin/mongosh-bin/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ultrabug@gentoo.org</email>
+ <name>Alexys Jacob</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mongodb-js/mongosh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/mongosh-bin/mongosh-bin-1.0.4.ebuild b/app-admin/mongosh-bin/mongosh-bin-1.0.4.ebuild
new file mode 100644
index 000000000000..4f81663b3bbd
--- /dev/null
+++ b/app-admin/mongosh-bin/mongosh-bin-1.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="The MongoDB Shell"
+HOMEPAGE="https://github.com/mongodb-js/mongosh https://www.mongodb.com/products/shell"
+
+SRC_URI_BASE="https://downloads.mongodb.com/compass/${MY_P}-linux"
+SRC_URI="amd64? ( ${SRC_URI_BASE}-x64.tgz -> ${MY_P}_x64.tgz )
+ arm64? ( ${SRC_URI_BASE}-arm64.tgz -> ${MY_P}_arm64.tgz )"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-4.0 ISC MIT WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="dev-libs/cyrus-sasl[kerberos]"
+
+src_unpack() {
+ if use amd64; then
+ S="${WORKDIR}/${MY_P}-linux-x64"
+ elif use arm64; then
+ S="${WORKDIR}/${MY_P}-linux-arm64"
+ fi
+
+ default
+}
+
+src_install() {
+ dobin bin/mongosh
+}