summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-09-10 15:16:36 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-09-11 12:58:21 +0200
commitf90cde87cce492feccf248192e31266ff5d7ca18 (patch)
treef256603508989a97e52a7a5425986afa091b4cf5 /app-admin/keepassx
parentapp-misc/geoclue: version bump 2.4.3 → 2.4.4 (diff)
downloadgentoo-f90cde87cce492feccf248192e31266ff5d7ca18.tar.gz
gentoo-f90cde87cce492feccf248192e31266ff5d7ca18.tar.bz2
gentoo-f90cde87cce492feccf248192e31266ff5d7ca18.zip
app-admin/keepassx: add missing handling of various cache updates, bug #577596
With permission from poly-c. Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/keepassx')
-rw-r--r--app-admin/keepassx/keepassx-2.0.2-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/keepassx/keepassx-2.0.2-r1.ebuild b/app-admin/keepassx/keepassx-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..519898f9c73e
--- /dev/null
+++ b/app-admin/keepassx/keepassx-2.0.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils vcs-snapshot xdg
+
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
+HOMEPAGE="http://www.keepassx.org/"
+SRC_URI="https://www.keepassx.org/releases/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 ) BSD GPL-2 LGPL-2.1 LGPL-3+ CC0-1.0 public-domain || ( LGPL-2.1 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(CHANGELOG)
+
+src_prepare() {
+ xdg_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ xdg_pkg_preinst
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_pkg_postrm
+}