summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/kedpm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/kedpm')
-rw-r--r--app-admin/kedpm/Manifest1
-rw-r--r--app-admin/kedpm/files/kedpm.desktop16
-rw-r--r--app-admin/kedpm/files/setup-doc.patch12
-rw-r--r--app-admin/kedpm/kedpm-0.4.0-r2.ebuild49
-rw-r--r--app-admin/kedpm/metadata.xml11
5 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/kedpm/Manifest b/app-admin/kedpm/Manifest
new file mode 100644
index 000000000000..aef9922a6e64
--- /dev/null
+++ b/app-admin/kedpm/Manifest
@@ -0,0 +1 @@
+DIST kedpm-0.4.0.tar.gz 61636 SHA256 f1dfb44a990110fddf132c9841f40aa2b9848ade4be56957a8a572574dc2fc28 SHA512 f6d73d4aab2b9184774e4a109bdf7401b96d9d9417e30a30d34958b9bee709e46676d68bb82e401b10b2eb32c56b6c8b1bb3947880cafb6e11d644d7f718a0f5 WHIRLPOOL 0a531e29ab66849fc5098ea8838bf53df340135650f312d5b1dc38231cddf797f02d3c3f8e2157b909bf954af5a65115d7814ba475924432a38d2b89341cf2df
diff --git a/app-admin/kedpm/files/kedpm.desktop b/app-admin/kedpm/files/kedpm.desktop
new file mode 100644
index 000000000000..29aa0fff8f3d
--- /dev/null
+++ b/app-admin/kedpm/files/kedpm.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Version=1.0
+Name=Ked Password Manager
+GenericName=Password Manager
+GenericName[ca]=Gestor de contrasenyes
+GenericName[es]=Gestor de contraseñas
+Comment=Manage passwords and related information
+Comment[ca]=Gestioneu contrasenyes i informació relacionada
+Comment[es]=Gestiona contraseñas e información relacionada
+Exec=kedpm
+Icon=/usr/share/kedpm/glade/logo.png
+Terminal=false
+Type=Application
+Categories=GNOME;Utility;
+StartupNotify=true
+MimeType=application/xml;
diff --git a/app-admin/kedpm/files/setup-doc.patch b/app-admin/kedpm/files/setup-doc.patch
new file mode 100644
index 000000000000..d8593e40f075
--- /dev/null
+++ b/app-admin/kedpm/files/setup-doc.patch
@@ -0,0 +1,12 @@
+--- setup.py 2004-02-29 12:45:48.000000000 +0100
++++ setup.py 2004-03-29 08:47:15.886238864 +0200
+@@ -52,8 +52,7 @@
+ url="http://kedpm.sourceforge.net/",
+ packages=['kedpm', 'kedpm.plugins', 'kedpm.frontends', 'kedpm.frontends.gtk'],
+ scripts=['scripts/kedpm'],
+- data_files=[(os.path.join('share', 'kedpm'), ['AUTHORS', 'COPYING', 'INSTALL']),
+- (os.path.join('share', 'kedpm', 'glade'),
++ data_files=[(os.path.join('share', 'kedpm', 'glade'),
+ [os.path.join('glade', 'kedpm.glade')] +
+ glob(os.path.join('glade', '*.png'))
+ )],
diff --git a/app-admin/kedpm/kedpm-0.4.0-r2.ebuild b/app-admin/kedpm/kedpm-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..1a6466da6ca8
--- /dev/null
+++ b/app-admin/kedpm/kedpm-0.4.0-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Ked Password Manager helps to manage large amounts of passwords and related information"
+HOMEPAGE="http://kedpm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="gtk"
+
+DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ gtk? ( >=dev-python/pygtk-2[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS CHANGES NEWS )
+
+python_prepare_all() {
+ # We want documentation to install in /usr/share/doc/kedpm
+ # not in /usr/share/kedpm as in original setup.py.
+ local PATCHES=(
+ "${FILESDIR}/setup-doc.patch"
+ )
+
+ # If we don't compiling with GTK support, let's change default
+ # frontend for kedpm to CLI.
+ use gtk || sed -i -e 's/"gtk" # default/"cli" # default/' scripts/kedpm
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" run_tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # menu item
+ domenu "${FILESDIR}/${PN}.desktop"
+}
diff --git a/app-admin/kedpm/metadata.xml b/app-admin/kedpm/metadata.xml
new file mode 100644
index 000000000000..a4448f8b98a8
--- /dev/null
+++ b/app-admin/kedpm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>key storing program</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">kedpm</remote-id>
+ </upstream>
+</pkgmetadata>