summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/calamares
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/calamares')
-rw-r--r--app-admin/calamares/Manifest1
-rw-r--r--app-admin/calamares/calamares-1.1.2-r1.ebuild77
-rw-r--r--app-admin/calamares/files/calamares-pkexec2
-rw-r--r--app-admin/calamares/metadata.xml21
4 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/calamares/Manifest b/app-admin/calamares/Manifest
new file mode 100644
index 000000000000..4f3c7bc63df7
--- /dev/null
+++ b/app-admin/calamares/Manifest
@@ -0,0 +1 @@
+DIST calamares-1.1.2.tar.gz 3642991 SHA256 6adf5777f51998a88b19f37c3dd4bb8256be4464106ffbd5d1393ef67109d49c SHA512 567bfae24691576fb814297d7db66f61b39a639b71b2191defb43fd0d2e56b9ccf70dfd666e1fd1faaa1b954c349aea96ad2b5d1b5d59bdc5a351cde6bbdcea6 WHIRLPOOL e6b88ec952d31088c138a6467b98bd66f739ee48daf7689b5e8356274565beddd602ae02df559d6aa9f6483f797da3b7e284d04071eb3e54cf7b8679abe3730a
diff --git a/app-admin/calamares/calamares-1.1.2-r1.ebuild b/app-admin/calamares/calamares-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..5f732d8e5a2f
--- /dev/null
+++ b/app-admin/calamares/calamares-1.1.2-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+inherit kde5 python-r1
+
+DESCRIPTION="Distribution-independent installer framework"
+HOMEPAGE="http://calamares.io"
+if [[ ${KDE_BUILD_TYPE} == live ]] ; then
+ EGIT_REPO_URI="git://github.com/${PN}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+IUSE="+networkmanager +upower"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-cpp/yaml-cpp-0.5.1
+ >=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep solid)
+ dev-qt/linguist-tools:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtquick1:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ sys-apps/dbus
+ sys-apps/dmidecode
+ sys-auth/polkit-qt[qt5]
+"
+
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-libs/libatasmart
+ net-misc/rsync
+ sys-apps/gptfdisk
+ >=sys-block/parted-3.0
+ || ( sys-boot/grub:2 sys-boot/gummiboot )
+ sys-boot/os-prober
+ sys-fs/squashfs-tools
+ sys-fs/udisks:2[systemd]
+ virtual/udev[systemd]
+ networkmanager? ( net-misc/networkmanager )
+ upower? ( sys-power/upower )
+"
+
+src_prepare() {
+ python_setup
+ export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
+ PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
+ PYTHON_CFLAGS="$(python_get_CFLAGS)"\
+ PYTHON_LIBS="$(python_get_LIBS)"
+ export QT_SELECT=qt5
+}
+
+src_configure() {
+ local mycmakeargs=( "-DWITH_PARTITIONMANAGER=1" )
+ kde5_src_configure
+ sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
+ sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
+}
+
+src_install() {
+ kde5_src_install
+ dobin "${FILESDIR}"/calamares-pkexec
+}
diff --git a/app-admin/calamares/files/calamares-pkexec b/app-admin/calamares/files/calamares-pkexec
new file mode 100644
index 000000000000..3300d3b70c61
--- /dev/null
+++ b/app-admin/calamares/files/calamares-pkexec
@@ -0,0 +1,2 @@
+#!/bin/sh
+pkexec "/usr/bin/calamares" "$@"
diff --git a/app-admin/calamares/metadata.xml b/app-admin/calamares/metadata.xml
new file mode 100644
index 000000000000..b719686ba39d
--- /dev/null
+++ b/app-admin/calamares/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <longdescription>
+ Calamares is a distribution-independent system installer, with an
+ advanced partitioning feature for both manual and automated
+ partitioning operations. It is the first installer with an automated
+ “Replace Partition” option, which makes it easy to reuse a partition
+ over and over for distribution testing. Calamares is designed to be
+ customizable by distribution maintainers without need for cumbersome
+ patching, thanks to third party branding and external modules support.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">calamares/calamares</remote-id>
+ </upstream>
+</pkgmetadata>
+