summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:21:11 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:56:00 -0400
commitfc850a31b71f8d706385e839aa7cc835a93ca17a (patch)
tree0ae0afad672ee46f7a41206c5cce123c403f802d
parentdev-util/ftjam: pass -std=gnu89 (diff)
downloadgentoo-fc850a31b71f8d706385e839aa7cc835a93ca17a.tar.gz
gentoo-fc850a31b71f8d706385e839aa7cc835a93ca17a.tar.bz2
gentoo-fc850a31b71f8d706385e839aa7cc835a93ca17a.zip
games-action/xpilot: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-action/xpilot/xpilot-4.5.5-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/games-action/xpilot/xpilot-4.5.5-r1.ebuild b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
index e76581df3051..9ecd8ae3d47c 100644
--- a/games-action/xpilot/xpilot-4.5.5-r1.ebuild
+++ b/games-action/xpilot/xpilot-4.5.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop toolchain-funcs
+inherit desktop flag-o-matic toolchain-funcs
DESCRIPTION="Multi-player 2D client/server space game"
HOMEPAGE="http://www.xpilot.org/"
@@ -49,6 +49,8 @@ src_prepare() {
}
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}