summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-09-17 08:47:59 +1000
committerSam James <sam@gentoo.org>2022-10-12 23:57:11 +0100
commitf2393153e6bbbedb6e88ba41c1c2552c86ff3b57 (patch)
treeb79ea9962cd50c6277007738cf58d6941e5a1dbe
parentmedia-gfx/blender: Add wayland useflags for live ebuild (diff)
downloadgentoo-f2393153e6bbbedb6e88ba41c1c2552c86ff3b57.tar.gz
gentoo-f2393153e6bbbedb6e88ba41c1c2552c86ff3b57.tar.bz2
gentoo-f2393153e6bbbedb6e88ba41c1c2552c86ff3b57.zip
games-engines/solarus: add 1.6.5, 9999
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-engines/solarus/Manifest1
-rw-r--r--games-engines/solarus/metadata.xml2
-rw-r--r--games-engines/solarus/solarus-1.6.5.ebuild79
-rw-r--r--games-engines/solarus/solarus-9999.ebuild79
4 files changed, 160 insertions, 1 deletions
diff --git a/games-engines/solarus/Manifest b/games-engines/solarus/Manifest
index 5a040945b687..17bfc3605252 100644
--- a/games-engines/solarus/Manifest
+++ b/games-engines/solarus/Manifest
@@ -1 +1,2 @@
DIST solarus-1.3.1-src.tar.gz 2450599 BLAKE2B e8aefa36d48753b1362283c8818b6efdc82c2d6ed7612c15d5e45b035a131ec6fd5792f85e4b956afa3e1d51e0dc311d7d6fabb5750b7b8781c69169b61fe1d9 SHA512 f52a46add1432a98931db8d26496371b5ff843151c8ac0fdaf1e774be37399d9be6c401f263a65aa08b96f3eebda367b4ccb07ef6cb9740b3112b01e4763556b
+DIST solarus-v1.6.5.tar.gz 15010899 BLAKE2B 96a67c7210c70d23d3fa08e24ee2c4cfbeb6e95dce7236ab860695bf4fc57aaa5d54b02e25ad2f10dfc498cc836bf83753d99cbeca1ff7bf496f7d589accbbf5 SHA512 3fc7473f1b7dd80cbcb0a7a639701f8b12bd40ee918a7853805bd54f877e752b4c31c26828e62248ca4594b3aed41a8c61a16be3b14b293f08d9ba938a723e91
diff --git a/games-engines/solarus/metadata.xml b/games-engines/solarus/metadata.xml
index 1633aef30a2d..16d609b36b2d 100644
--- a/games-engines/solarus/metadata.xml
+++ b/games-engines/solarus/metadata.xml
@@ -9,6 +9,6 @@
<flag name="doc">Install doxygen developer documentation.</flag>
</use>
<upstream>
- <remote-id type="github">christopho/solarus</remote-id>
+ <remote-id type="gitlab">solarus-games/solarus</remote-id>
</upstream>
</pkgmetadata>
diff --git a/games-engines/solarus/solarus-1.6.5.ebuild b/games-engines/solarus/solarus-1.6.5.ebuild
new file mode 100644
index 000000000000..dd0d28447c5d
--- /dev/null
+++ b/games-engines/solarus/solarus-1.6.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 luajit )
+
+inherit cmake lua-single optfeature virtualx
+
+DESCRIPTION="An open-source Zelda-like 2D game engine"
+HOMEPAGE="https://www.solarus-games.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/solarus-games/solarus.git"
+ EGIT_BRANCH="dev"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/solarus-games/solarus/-/archive/v${PV}/solarus-v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ dev-games/physfs
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libmodplug
+ >=media-libs/libsdl2-2.0.1[X,joystick,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ >=media-libs/sdl2-ttf-2.0.12
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+
+if ! [[ ${PV} == 9999 ]]; then
+ S="${WORKDIR}/solarus-v${PV}"
+fi
+
+src_configure() {
+ local mycmakeargs=( -DSOLARUS_USE_LUAJIT="$(usex lua_single_target_luajit)" )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ cd doc && doxygen || die
+ fi
+}
+
+src_test() {
+ # lua/bugs-{1200,1210} are GUI tests that require X
+ # With EAPI 8, one of the last tests hangs with >= j3
+ virtx cmake_src_test -j1
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r doc/${PV%.*}/html/*
+}
+
+pkg_postinst() {
+ optfeature "the Solarus Quest Editor" games-misc/solarus-quest-editor
+}
diff --git a/games-engines/solarus/solarus-9999.ebuild b/games-engines/solarus/solarus-9999.ebuild
new file mode 100644
index 000000000000..dd0d28447c5d
--- /dev/null
+++ b/games-engines/solarus/solarus-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 luajit )
+
+inherit cmake lua-single optfeature virtualx
+
+DESCRIPTION="An open-source Zelda-like 2D game engine"
+HOMEPAGE="https://www.solarus-games.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/solarus-games/solarus.git"
+ EGIT_BRANCH="dev"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/solarus-games/solarus/-/archive/v${PV}/solarus-v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ dev-games/physfs
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libmodplug
+ >=media-libs/libsdl2-2.0.1[X,joystick,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ >=media-libs/sdl2-ttf-2.0.12
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+
+if ! [[ ${PV} == 9999 ]]; then
+ S="${WORKDIR}/solarus-v${PV}"
+fi
+
+src_configure() {
+ local mycmakeargs=( -DSOLARUS_USE_LUAJIT="$(usex lua_single_target_luajit)" )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ cd doc && doxygen || die
+ fi
+}
+
+src_test() {
+ # lua/bugs-{1200,1210} are GUI tests that require X
+ # With EAPI 8, one of the last tests hangs with >= j3
+ virtx cmake_src_test -j1
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r doc/${PV%.*}/html/*
+}
+
+pkg_postinst() {
+ optfeature "the Solarus Quest Editor" games-misc/solarus-quest-editor
+}