summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:00:31 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:03 +0300
commite483c11b46f007351a6e5b294a11860c1502883c (patch)
tree5401a06b5a278161572b2e3ccf32a508a39223ea
parentmate-base/mate-applets: drop 1.27.1 (diff)
downloadgentoo-e483c11b46f007351a6e5b294a11860c1502883c.tar.gz
gentoo-e483c11b46f007351a6e5b294a11860c1502883c.tar.bz2
gentoo-e483c11b46f007351a6e5b294a11860c1502883c.zip
mate-base/mate-applets: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--mate-base/mate-applets/Manifest1
-rw-r--r--mate-base/mate-applets/mate-applets-1.28.0.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/mate-base/mate-applets/Manifest b/mate-base/mate-applets/Manifest
index 638c8837ba91..aa5799052c76 100644
--- a/mate-base/mate-applets/Manifest
+++ b/mate-base/mate-applets/Manifest
@@ -1 +1,2 @@
DIST mate-applets-1.26.1.tar.xz 8475672 BLAKE2B 0f67f7dfd649c6168f51673f04287e49717ebf7077da63a631844594658d78079df55fd4d25e2be5e299c00d2ea3659ae23140bb508adc327b7c87a74ac4dd19 SHA512 7243825098f9101542b9eead2f60ac7f12e044ceb685da92a29fe72b2dc1271e1fa34dbc4c47148e2331a2af79d69f787dc8856c7112b75ef0a3dea97e4ab8fd
+DIST mate-applets-1.28.0.tar.xz 8465116 BLAKE2B ed2a13e8c79daeb88706ee4b6ad3146e2d3795e6a430bfc494672cf4a0de2ec088ba453368afdc530ca7fffff82893d4d3929e21e224a418bd4382cfe36e5812 SHA512 badc4fa6a95b840033f12688ba0d2f0d9e0558fe4c0a4a8d97eba8fc1afc8e8611d81f343efb9703d5edc9c2c33b22fc2db624660a3e1d970209567da25581a7
diff --git a/mate-base/mate-applets/mate-applets-1.28.0.ebuild b/mate-base/mate-applets/mate-applets-1.28.0.ebuild
new file mode 100644
index 000000000000..3476bd7daa24
--- /dev/null
+++ b/mate-base/mate-applets/mate-applets-1.28.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Applets for the MATE Desktop and Panel"
+LICENSE="CC-BY-SA-3.0 FDL-1.1+ GPL-2+ GPL-3+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +cpupower ipv6 netlink policykit +upower"
+
+REQUIRED_USE="policykit? ( cpupower )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ >=dev-libs/libxml2-2.5:2
+ >=gnome-base/libgtop-2.12.0:2=
+ >=gnome-extra/gucharmap-3.0:2.90
+ >=mate-base/mate-panel-1.25.2
+ >=net-wireless/wireless-tools-28_pre9:0
+ >=sys-apps/dbus-1.10.0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/gtksourceview:4
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ >=x11-libs/libwnck-3.0:3
+ x11-libs/pango
+ cpupower? (
+ sys-power/cpupower
+ policykit? ( >=sys-auth/polkit-0.97:0 )
+ )
+ netlink? (
+ dev-libs/libnl:3
+ )
+ upower? ( >=sys-power/upower-0.99.8 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ mate-base/caja
+ mate-base/mate-desktop
+ >=mate-base/mate-settings-daemon-1.6
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ app-text/rarian
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+
+ # configure.ac logic is a little hinky
+ # and ignores --enable flags for cpufreq
+ use cpupower || myconf="--disable-cpufreq"
+
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ $(use_with X x) \
+ $(use_with upower) \
+ $(use_with netlink nl) \
+ $(use_enable ipv6) \
+ $(use_enable policykit polkit) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check
+}
+
+src_install() {
+ mate_src_install
+
+ local APPLETS="accessx-status battstat charpick command cpufreq drivemount
+ geyes mateweather multiload netspeed stickynotes
+ timerapplet trashapplet"
+
+ for applet in ${APPLETS}; do
+ docinto ${applet}
+
+ for d in AUTHORS ChangeLog NEWS README README.themes TODO; do
+ [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
+ done
+ done
+}