summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-23 13:53:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-23 14:12:44 +0200
commitbe38853b08bafa5fe67e284f4f17e33503d5a7b0 (patch)
treee9d5f1d3ddfc21b6029ac78a0feb1a16a06e9a17
parentapp-misc/ytree: remove old (diff)
downloadgentoo-be38853b08bafa5fe67e284f4f17e33503d5a7b0.tar.gz
gentoo-be38853b08bafa5fe67e284f4f17e33503d5a7b0.tar.bz2
gentoo-be38853b08bafa5fe67e284f4f17e33503d5a7b0.zip
dev-python/cmd2: Disable test relying on 'vi'
Bug: https://bugs.gentoo.org/710174 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cmd2/cmd2-0.10.1.ebuild5
-rw-r--r--dev-python/cmd2/cmd2-1.0.2.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/cmd2/cmd2-0.10.1.ebuild b/dev-python/cmd2/cmd2-0.10.1.ebuild
index 4da2056c28bd..c6dd48a3be49 100644
--- a/dev-python/cmd2/cmd2-0.10.1.ebuild
+++ b/dev-python/cmd2/cmd2-0.10.1.ebuild
@@ -28,6 +28,11 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ sed -i -e 's:test_which_editor_good:_&:' tests/test_cmd2.py || die
+ distutils-r1_src_prepare
+}
+
src_test() {
# tests rely on very specific text wrapping...
local -x COLUMNS=80
diff --git a/dev-python/cmd2/cmd2-1.0.2.ebuild b/dev-python/cmd2/cmd2-1.0.2.ebuild
index 20add50e79bb..67caee784fa9 100644
--- a/dev-python/cmd2/cmd2-1.0.2.ebuild
+++ b/dev-python/cmd2/cmd2-1.0.2.ebuild
@@ -28,6 +28,11 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ sed -i -e 's:test_which_editor_good:_&:' tests/test_cmd2.py || die
+ distutils-r1_src_prepare
+}
+
src_test() {
# tests rely on very specific text wrapping...
local -x COLUMNS=80