summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-08 15:45:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-08 17:54:53 +0100
commitb588b4b55054abad5df51ac9ba628a2d28c24199 (patch)
tree13bb21776bf77d92e6a68bd4da32c12a1eee66f8
parentdev-python/cbor2: Bump to 5.4.6 (diff)
downloadgentoo-b588b4b55054abad5df51ac9ba628a2d28c24199.tar.gz
gentoo-b588b4b55054abad5df51ac9ba628a2d28c24199.tar.bz2
gentoo-b588b4b55054abad5df51ac9ba628a2d28c24199.zip
dev-python/sphinx_ansible_theme: Bump to 0.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx_ansible_theme/Manifest1
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinx_ansible_theme/Manifest b/dev-python/sphinx_ansible_theme/Manifest
index b49a27c3d206..6ba68e338042 100644
--- a/dev-python/sphinx_ansible_theme/Manifest
+++ b/dev-python/sphinx_ansible_theme/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-ansible-theme-0.10.0.tar.gz 49377 BLAKE2B 79d373387c2f6c75e2a352bfd169a8224b38cc5e9c75082cf3808e5318cf5be3bafce81d09e88adc8eafd5b1d98d8a20b081c3d076f2e91822a43c21959b0e82 SHA512 c7dab9040983fd946607e8ef2e3193be668fc4ba3d1ab747571297f896618e2300e4e102bacf277b3172da7292a15072c4522295b1d01d697293fb57edffc1ea
+DIST sphinx-ansible-theme-0.10.1.tar.gz 49575 BLAKE2B 605e153739605e85da19022ececaee8884df8d200ee5ce65a0e695e4bd4a305b5997624e18b593a3566b17c2cd9336b961280c7da6758d370a42555321a2de69 SHA512 8e5eada24f536320e3d7bb83138ebc38c1353db6b4cc0c7eaca95078ccb4d645c5e62ce83fe1ba88aa25c13999914d7d93b817eb893d47802eee9cd40cba483d
DIST sphinx-ansible-theme-0.9.1.tar.gz 34505 BLAKE2B 533e665b30f5aa450e4a2240c55c4992340b9f6ee03d27758bf119dfe2eef987fbd4b98136349af376557d8e9a78e5391a648b9886136995d05410b0c26561f2 SHA512 f78602af8affe7be59988f466cf6a2aa67e174086f338cad855369a7bbee5a76d07bcffa8406dea5a819127b26d69e29b0d90dab38b82524b3e317f9082d0379
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild
new file mode 100644
index 000000000000..91f35e9574e9
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN//_/-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A reusable Ansible Sphinx theme"
+HOMEPAGE="
+ https://github.com/ansible-community/sphinx_ansible_theme/
+ https://pypi.org/project/sphinx-ansible-theme/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-7.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/ansible-pygments' \
+ 'dev-python/sphinx-notfound-page'