summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-05 13:39:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-08 17:56:21 +0100
commita770c62efb886abdfd8fa52fbf312362ab62bf21 (patch)
tree79183a2442c076d9054c9ebf476db53a27ec374a
parentllvm.eclass: Set LLVM_SLOT in pkg_setup() (diff)
downloadgentoo-a770c62efb886abdfd8fa52fbf312362ab62bf21.tar.gz
gentoo-a770c62efb886abdfd8fa52fbf312362ab62bf21.tar.bz2
gentoo-a770c62efb886abdfd8fa52fbf312362ab62bf21.zip
media-libs/mesa: Disable EH/RTTI on LLVM 16+
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/28549 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-22.3.0.ebuild9
-rw-r--r--media-libs/mesa/mesa-9999.ebuild9
2 files changed, 18 insertions, 0 deletions
diff --git a/media-libs/mesa/mesa-22.3.0.ebuild b/media-libs/mesa/mesa-22.3.0.ebuild
index e121c4c2f319..f39169af89a2 100644
--- a/media-libs/mesa/mesa-22.3.0.ebuild
+++ b/media-libs/mesa/mesa-22.3.0.ebuild
@@ -410,6 +410,15 @@ multilib_src_configure() {
use vulkan-overlay && vulkan_layers+=",overlay"
emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
+ # In LLVM 16, we've switched to building LLVM with EH/RTTI disabled
+ # to match upstream defaults. Mesa requires being built the same way.
+ # https://bugs.gentoo.org/883955
+ if [[ ${LLVM_SLOT} -ge 16 ]]; then
+ emesonargs+=(
+ -Dcpp_rtti=false
+ )
+ fi
+
emesonargs+=(
$(meson_use test build-tests)
-Dglx=$(usex X dri disabled)
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index e121c4c2f319..f39169af89a2 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -410,6 +410,15 @@ multilib_src_configure() {
use vulkan-overlay && vulkan_layers+=",overlay"
emesonargs+=(-Dvulkan-layers=${vulkan_layers#,})
+ # In LLVM 16, we've switched to building LLVM with EH/RTTI disabled
+ # to match upstream defaults. Mesa requires being built the same way.
+ # https://bugs.gentoo.org/883955
+ if [[ ${LLVM_SLOT} -ge 16 ]]; then
+ emesonargs+=(
+ -Dcpp_rtti=false
+ )
+ fi
+
emesonargs+=(
$(meson_use test build-tests)
-Dglx=$(usex X dri disabled)