summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-13 05:55:47 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-13 05:57:10 +0200
commit8da1fa6031b636d6ee70c0ae7301e4875a459802 (patch)
tree43580a3fe8efd40570e1d16e7d0ddd226b76851b
parentdev-python/bandit: Bump to 1.7.9 (diff)
downloadgentoo-8da1fa6031b636d6ee70c0ae7301e4875a459802.tar.gz
gentoo-8da1fa6031b636d6ee70c0ae7301e4875a459802.tar.bz2
gentoo-8da1fa6031b636d6ee70c0ae7301e4875a459802.zip
dev-python/python-box: Bump to 7.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-box/Manifest1
-rw-r--r--dev-python/python-box/python-box-7.2.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/python-box/Manifest b/dev-python/python-box/Manifest
index 19f8e6c78cf2..8bd011c20916 100644
--- a/dev-python/python-box/Manifest
+++ b/dev-python/python-box/Manifest
@@ -1 +1,2 @@
DIST Box-7.1.1.gh.tar.gz 87515 BLAKE2B 388944c3a577105ce1e12e9abff7da148d028db88d8070a09e6abe190882acdbfa4cf9d773af6cbae7e945603dc13d3d853253dc18b0d2d2b17c678293583b8a SHA512 60e44eda013a5ab1de2215d156caf2567a24b0471ee20e52096137ad761e92c3ca20d9f3967a21e38ac924488a2b76399c4ea1bc86b652dd72d7494ce22effee
+DIST Box-7.2.0.gh.tar.gz 87699 BLAKE2B d6f033919e5451adfdcb0c14c28a47e25b619eb531280a39b68912179ad3a21638d4fadd6dbee2b09bc445b1adc2dd31e042d1e816dc5fc36098ea5eadab8a30 SHA512 8f2ec95a0539c8000d08353eccd66dd9de4049408b0cef9095f3bf98486424214e1d47ef5c408e425c5c2958652624efa512701138d91d51356f07795c508b9f
diff --git a/dev-python/python-box/python-box-7.2.0.ebuild b/dev-python/python-box/python-box-7.2.0.ebuild
new file mode 100644
index 000000000000..496d366fbbed
--- /dev/null
+++ b/dev-python/python-box/python-box-7.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=Box-${PV}
+DESCRIPTION="Python dictionaries with advanced dot notation access"
+HOMEPAGE="
+ https://github.com/cdgriffith/Box/
+ https://pypi.org/project/python-box/
+"
+SRC_URI="
+ https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+native-extensions"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if ! use native-extensions; then
+ # a cheap hack, extensions are auto-disabled if Cython.Build
+ # is not importable
+ > Cython.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf box || die
+ epytest
+}