summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-08 15:30:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-08 17:54:47 +0100
commit80c508500036d2701ce2dc870cab8aeeab0256b3 (patch)
tree909b769a8b1ee5dcfdc538c74fdb90caaf8d1800
parentdev-python/translate-toolkit: Bump to 3.8.0 (diff)
downloadgentoo-80c508500036d2701ce2dc870cab8aeeab0256b3.tar.gz
gentoo-80c508500036d2701ce2dc870cab8aeeab0256b3.tar.bz2
gentoo-80c508500036d2701ce2dc870cab8aeeab0256b3.zip
dev-python/nuitka: Bump to 1.2.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.2.6.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index ca0ae7ff7cb6..b38feb53ac76 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-1.2.3.tar.gz 3958335 BLAKE2B c2d47e7ff355492fb72f224be92445849c3fce13768ba7957cf4bbbbc9cd4e0ec7c3904e5465ad543e16d1419a01b42cd4399b816e1ff56e2c8ea5c57fddbc04 SHA512 1c842c21764bd0dc9bf68bb26506959b35e54d03c1d6d6b9c179289ec073ed07b75d6709a3c73ac3e14bb988a7b2f5a88f7dfcce55a25eab1c5e4b294b15d4f4
DIST Nuitka-1.2.4.tar.gz 3958942 BLAKE2B ca3be2453815949b05f8a74dc783c58125ebbda038a86f22d273c6e4ef6c8b3fe3d238b3abedb0062ace59a0f60545312f8ad8af056b13c975106ee0c7563fa7 SHA512 7a160f7b12ba9dd66af2d3c798bafd4b2d4f60068acb18be5dc9246c811df58b6f2e6b1c3610ed045d7a73042728b53b92c36b239cb88931d500c904e7018847
+DIST Nuitka-1.2.6.tar.gz 3959091 BLAKE2B b326409f49d722bcac7df3e2c5caae7fb9ccf2b2991d2cf003a4db7bd268af95b7423da3b69b93b45c2aa1e3461faac90872b01f2d2277c5e9f7c71bedb0df56 SHA512 b12f694f8ac26213fd1242c66c2a37be1940bafef8a4949f0e401f056a1f72a010d1df237a828317ed0c88530206c31e617f03e4bccf6c934b967f8ddaef330f
diff --git a/dev-python/nuitka/nuitka-1.2.6.ebuild b/dev-python/nuitka/nuitka-1.2.6.ebuild
new file mode 100644
index 000000000000..b55f0385d58a
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.2.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}