summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-09 20:33:06 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-09 20:58:23 +0300
commit67b8bda03bf13fc75b2da42139ee9564f9d0c35c (patch)
treeacabc74ee3b690a1dfba4d95c81690899ee3a632
parentdev-python/boto3: add 1.24.47 (diff)
downloadgentoo-67b8bda03bf13fc75b2da42139ee9564f9d0c35c.tar.gz
gentoo-67b8bda03bf13fc75b2da42139ee9564f9d0c35c.tar.bz2
gentoo-67b8bda03bf13fc75b2da42139ee9564f9d0c35c.zip
app-admin/awscli: add 1.25.47
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.47.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 624c83ce1a38..d03a387c6f41 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST aws-cli-1.25.36.gh.tar.gz 2237211 BLAKE2B fbab136a1c1211646c1213357cd80068da376e4aceb38007c14b2fb670a694b37aaa0157d58eb4edf10c3a9b5a700575a42b48c06db1c4034f39ccda584be19a SHA512 b66ba357085c82dcefc4ed9a6d0765d8768c8d216cd255056be055d3b5f604b62bace3eacccac83275d7c9487847f7de542efa804f8e0f454947cfe453d6e705
DIST aws-cli-1.25.41.gh.tar.gz 2238897 BLAKE2B b0e4d1b96048971f41a0fce9c9149154778177ec8569f467cd210edaa063d629ea6998c1ebfa4506f8b2cca65caef7f73b307ef6aeec683801045c6121f85a8c SHA512 712c237181b166cdf1148ca4b3588a92939dbbfbaa5cdff9bffd8e2da35089539ef3b0b0ba271b234918796cd5fd83bf2a59e29c974f9e341d0e42e05bb8b69e
DIST aws-cli-1.25.46.gh.tar.gz 2240196 BLAKE2B fde009f43c4a9c900b0ce66ad540252b87bd023e0070efd5403beae61fe72f4e5d42e0c0402eb36f0b45a08f8769f49ffeec404dbf9d4d58cb8ae2be72caf81e SHA512 387c428e1643c21b7598962b18d19929bc26747ed80a041bda31d2bb6239239f2693c272ba320616320be3ff1a536e6af859a289f4fb0813e0c9b89978da56f8
+DIST aws-cli-1.25.47.gh.tar.gz 2241028 BLAKE2B 6aea17029d28bf0875f58472ab27e244e2ace10d1d4d56e156c5fe97462d9ec2e10869609bbd19134edcdd3deba19235a39d409ce11617cf914d856cb325ef59 SHA512 1e76aa939f3098a19bb64cd79fd265d70bf3d96a0b92411c5d72d8e9b0635d0cfde70c6b4d3effce5ac8c82b0ddd84b761b2ce0b131ac1ed2fba9e0222057764
diff --git a/app-admin/awscli/awscli-1.25.47.ebuild b/app-admin/awscli/awscli-1.25.47.ebuild
new file mode 100644
index 000000000000..9f176fa05cc8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.47.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}