summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-24 02:12:09 +0100
committerSam James <sam@gentoo.org>2022-07-24 02:25:15 +0100
commit66a2570eaf4e177de052f6145b76459d29471c28 (patch)
tree82ee1499f8e3e1bf2ea9533c89d6a7ed5ef3024d
parentdev-haskell/email-validate: drop 2.3.2.13 (diff)
downloadgentoo-66a2570eaf4e177de052f6145b76459d29471c28.tar.gz
gentoo-66a2570eaf4e177de052f6145b76459d29471c28.tar.bz2
gentoo-66a2570eaf4e177de052f6145b76459d29471c28.zip
dev-haskell/aws: drop 0.22-r1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/aws/aws-0.22-r1.ebuild79
-rw-r--r--dev-haskell/aws/metadata.xml3
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-haskell/aws/aws-0.22-r1.ebuild b/dev-haskell/aws/aws-0.22-r1.ebuild
deleted file mode 100644
index d5a5b18362a0..000000000000
--- a/dev-haskell/aws/aws-0.22-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.4.9999
-#hackport: flags: networkbsd:network-3
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Amazon Web Services (AWS) for Haskell"
-HOMEPAGE="https://github.com/aristidb/aws"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+network-3 examples"
-
-RESTRICT=test # requires aws account
-
-RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
- >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
- >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
- >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
- >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
- >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
- >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
- >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.6:=[profile?]
- >=dev-haskell/conduit-1.3:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
- >=dev-haskell/conduit-extra-1.3:=[profile?] <dev-haskell/conduit-extra-1.4:=[profile?]
- >=dev-haskell/cryptonite-0.11:=[profile?]
- >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.8:=[profile?]
- >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
- >=dev-haskell/http-client-tls-0.3:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
- >=dev-haskell/http-conduit-2.3:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
- >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-1.0:=[profile?]
- >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
- dev-haskell/memory:=[profile?]
- >=dev-haskell/monad-control-0.3:=[profile?]
- >=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-3:=[profile?]
- >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?]
- >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
- >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
- >=dev-haskell/scientific-0.3:=[profile?]
- >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
- >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
- >=dev-haskell/text-0.11:=[profile?]
- >=dev-haskell/unordered-containers-0.2:=[profile?]
- >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
- >=dev-haskell/vector-0.10:=[profile?]
- >=dev-haskell/xml-conduit-1.8:=[profile?] <dev-haskell/xml-conduit-2.0:=[profile?]
- >=dev-lang/ghc-7.8.2:=
- examples? ( >=dev-haskell/errors-2.0:=[profile?] )
- network-3? ( >=dev-haskell/network-3:=[profile?] <dev-haskell/network-4:=[profile?]
- >=dev-haskell/network-bsd-2.8:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?] )
- !network-3? ( >=dev-haskell/network-2:=[profile?] <dev-haskell/network-3:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( >=dev-haskell/aeson-0.7
- >=dev-haskell/http-client-0.3 <dev-haskell/http-client-0.7
- >=dev-haskell/lifted-base-0.2
- >=dev-haskell/mtl-2.1
- >=dev-haskell/quickcheck-2.7
- >=dev-haskell/quickcheck-instances-0.3
- >=dev-haskell/tasty-0.8
- >=dev-haskell/tasty-hunit-0.8
- >=dev-haskell/tasty-quickcheck-0.8
- >=dev-haskell/text-1.1
- >=dev-haskell/transformers-base-0.4
- !examples? ( >=dev-haskell/errors-2.0 ) )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag examples examples) \
- $(cabal_flag network-3 networkbsd)
-}
diff --git a/dev-haskell/aws/metadata.xml b/dev-haskell/aws/metadata.xml
index 83ba450bb8bd..cc08513f82e8 100644
--- a/dev-haskell/aws/metadata.xml
+++ b/dev-haskell/aws/metadata.xml
@@ -5,9 +5,6 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <use>
- <flag name="network-3">Use network-3</flag>
- </use>
<longdescription>
Bindings for Amazon Web Services (AWS), with the aim of supporting all AWS services. To see a high level overview of the library, see the README at &lt;https://github.com/aristidb/aws/blob/master/README.org&gt;.
</longdescription>