summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-08 15:41:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-08 17:54:49 +0100
commit5c1c21fc893f5a1ef0f48f1e3d173729bcbc68d2 (patch)
tree9cf529cc5ce974cce8635e8aedfd220b4cbd1af9
parentdev-python/blosc: Bump to 1.11.0 (diff)
downloadgentoo-5c1c21fc893f5a1ef0f48f1e3d173729bcbc68d2.tar.gz
gentoo-5c1c21fc893f5a1ef0f48f1e3d173729bcbc68d2.tar.bz2
gentoo-5c1c21fc893f5a1ef0f48f1e3d173729bcbc68d2.zip
dev-python/botocore: Bump to 1.29.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.25.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index daff95b3af4d..4b4030e8af1f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,4 +6,5 @@ DIST botocore-1.29.21.gh.tar.gz 10994190 BLAKE2B 00a40dd701f659f63c0c0862e96922a
DIST botocore-1.29.22.gh.tar.gz 10999477 BLAKE2B 90987611453768b9c7c00ea8f6b1645bb8e5bed8ecb8b75c95452a2f20208ffed22182f8ea24bedb03f213826c3d46963f393ffc3f1465ae99620ff7f35240b7 SHA512 23c6ed2d0a9fed97467d568773d886773a06f6e4efffabbfad3b285f4d8f1844e82025b73e7fadd8c29d304c4f27e5385f63896b6ce0250e2af8b950b9a3e014
DIST botocore-1.29.23.gh.tar.gz 11001723 BLAKE2B d1cfefb3bc25094948a1450ee7159e81d640301eca756702e8debcfa30858c22c77c273043584641888d85c46d3be800c65c2c800ecfc83b2760e7ea40e9a03b SHA512 454ac41097385838d286f3a3d9cc44e076fea8608313895ae657683ea5441328704eaa1b46a22076cad5b7e91eead5291cd036a188ab907b80173f2b755d6160
DIST botocore-1.29.24.gh.tar.gz 11006663 BLAKE2B 195933b78bd0c5c5881cd697c1c61c6f40557d51edb7510e40ecdd31aae80a72fe3c33946e718a98b19a1f8af6d8cc687e047e5cd0b662de9f2d0ca3b53583e3 SHA512 e6dd5a88bf6539f02d27054d5825688b80a2a582e5ebd04d31d887e6baa31a4ba54aa0ba0c0e03156b4ad22815f6aa8f8f8986c3767180a04b284341223f4c60
+DIST botocore-1.29.25.gh.tar.gz 11008437 BLAKE2B 5a569d52065c2f448adb8c765e51e8338ce0bc2ae4b13e0f39a98af319aa1a31ef3a1eb4014aae8c497ab68a234dc2d16798a0d8b7c626e0ea81da4d2489ed7a SHA512 274a713d26cc723914824cdaf729d7537b5104957751b6d4b0c974e9f45a54ee09bd1853d1ab89dec2fb3b5a5b74102fa658c1f9478a4b4301b950e44f0f1fd5
DIST botocore-1.29.8.gh.tar.gz 10636661 BLAKE2B 3ebd9e5cb6cc1a9d4ddb877e806e0a845e6a19a4604b4489dbdb9a0f35251201de5d7062f3b0193db3e28f5170d8c3315fdc0b2bec7668a61880ff3e9305d3bc SHA512 c4a1a3993576bd0340de4eeb25e10650219e9d74c21f7e51e5298120bc92a8359143c38d5a991b940316fc5eac483e4e838298881a5c068fa91dc3ebf92a7f5a
diff --git a/dev-python/botocore/botocore-1.29.25.ebuild b/dev-python/botocore/botocore-1.29.25.ebuild
new file mode 100644
index 000000000000..eed342eb3cfa
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.25.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}